summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-21 04:32:07 +0000
committerSam James <sam@gentoo.org>2020-10-21 04:32:07 +0000
commit5257863dc17921bfa3e788d22f4c23fda4da3596 (patch)
tree9c4ad7d79fb815ba9c6318ad1d5e5d71b1636bac /dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r1.ebuild
parentdev-libs/nspr: Stabilize 4.29 sparc, #750254 (diff)
downloadgentoo-5257863dc17921bfa3e788d22f4c23fda4da3596.tar.gz
gentoo-5257863dc17921bfa3e788d22f4c23fda4da3596.tar.bz2
gentoo-5257863dc17921bfa3e788d22f4c23fda4da3596.zip
dev-ml/pcre-ocaml: drop obsolete configurator dep
We want dune-configurator now (already added). configurator blocks dune-configuator. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r1.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r1.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r1.ebuild
new file mode 100644
index 000000000000..6605758e767c
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.4.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+S="${WORKDIR}/pcre-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples +ocamlopt"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-ml/dune-configurator"
+RDEPEND=">=dev-libs/libpcre-4.5"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/stdio
+"
+
+src_install() {
+ dune_src_install pcre
+
+ if use examples ; then
+ dodoc -r examples
+ fi
+}