summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/parmap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/parmap')
-rw-r--r--dev-ml/parmap/Manifest1
-rw-r--r--dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch16
-rw-r--r--dev-ml/parmap/metadata.xml8
-rw-r--r--dev-ml/parmap/parmap-1.0_rc6.ebuild51
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-ml/parmap/Manifest b/dev-ml/parmap/Manifest
new file mode 100644
index 000000000000..643dd716bf53
--- /dev/null
+++ b/dev-ml/parmap/Manifest
@@ -0,0 +1 @@
+DIST parmap-1.0_rc6.tar.gz 97083 SHA256 25e2eeb2ec8b1dedc8067443ddcddf4ab0ff2e3821da888338146af69e8fd9e6 SHA512 5378a8ce03d3a4d139d06093bd29fa83eca13b6e74be14d379337c9a08ebac39b23920925375c753c63c7f62970f7f899a9d6cbf8a5001b262293cf52e9ea5c1 WHIRLPOOL 28c11c3ef9d4b0fb56fde988dc62e2993a313445005b657838cad41e9768a13a65535d69d81cac792bc8a95038521fe130488e25dcf87ef25d61d9533fea6729
diff --git a/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch b/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch
new file mode 100644
index 000000000000..96a656239b6b
--- /dev/null
+++ b/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch
@@ -0,0 +1,16 @@
+Author: Rémi Cardona
+https://bugs.gentoo.org/show_bug.cgi?id=553596
+https://github.com/rdicosmo/parmap/pull/36
+
+--- configure.ac 2015-07-03 23:59:19.361723234 +0200
++++ configure.ac 2015-07-03 23:59:48.161216749 +0200
+@@ -27,7 +27,7 @@
+ AC_CONFIG_HEADERS([config.h])
+
+-t=`$OCAMLBUILD -use-ocamlfind &> /dev/null; echo $?`
+-if test $t == 0 ; then
++t=`$OCAMLBUILD -use-ocamlfind > /dev/null 2>&1 ; echo $?`
++if test "$t" = 0 ; then
+ AC_MSG_RESULT(ocaml version $OCAMLVERSION. Use standard Makefile)
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/dev-ml/parmap/metadata.xml b/dev-ml/parmap/metadata.xml
new file mode 100644
index 000000000000..11d4f4b68712
--- /dev/null
+++ b/dev-ml/parmap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">rdicosmo/parmap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/parmap/parmap-1.0_rc6.ebuild b/dev-ml/parmap/parmap-1.0_rc6.ebuild
new file mode 100644
index 000000000000..e936ac3bc6a7
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.0_rc6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils autotools
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library allowing to exploit multicore architectures for OCaml programs with minimal modifications"
+HOMEPAGE="http://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocaml-autoconf"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-bashisms.patch"
+ eautoreconf
+}
+
+src_test() {
+ mkdir "${WORKDIR}/tmpinstall" || die
+ emake \
+ OCAMLLIBDIR="ocaml" \
+ DESTDIR="${WORKDIR}/tmpinstall" \
+ install
+ export OCAMLPATH="${WORKDIR}/tmpinstall/ocaml"
+ emake tests
+ cd _build/tests || die
+ for i in $(find . -type f -executable) ; do
+ ${i} || die
+ done
+}
+
+src_install() {
+ emake \
+ OCAMLLIBDIR="$(get_libdir)/ocaml" \
+ MANDIR="${ED}/usr/share/man/man3o" \
+ DESTDIR="${ED}/usr" \
+ install
+ dodoc AUTHORS ChangeLog README
+}