summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-28 03:54:52 +0000
committerSam James <sam@gentoo.org>2020-10-28 03:55:07 +0000
commit58aef54033c50133abc06a90aad6f658cc03ccbb (patch)
tree0da59d8ec8eebb1d427712e2bac6703a0c297eb2 /dev-ml/parmap/parmap-1.1.1.ebuild
parentdev-ml/mmap: bump to 1.1.0 (diff)
downloadgentoo-58aef54033c50133abc06a90aad6f658cc03ccbb.tar.gz
gentoo-58aef54033c50133abc06a90aad6f658cc03ccbb.tar.bz2
gentoo-58aef54033c50133abc06a90aad6f658cc03ccbb.zip
dev-ml/parmap: bump to 1.1.1
Closes: https://bugs.gentoo.org/719514 Closes: https://bugs.gentoo.org/704314 Closes: https://bugs.gentoo.org/614734 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/parmap/parmap-1.1.1.ebuild')
-rw-r--r--dev-ml/parmap/parmap-1.1.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/parmap/parmap-1.1.1.ebuild b/dev-ml/parmap/parmap-1.1.1.ebuild
new file mode 100644
index 000000000000..e4107295d2a0
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library to exploit multicore architectures for OCaml programs"
+HOMEPAGE="https://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}"