summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 21:34:00 +0000
committerSam James <sam@gentoo.org>2020-10-17 21:34:00 +0000
commit86ff62abbee0c7acc3d09f10f9a96fef3403c22b (patch)
tree107c096522564f18d9f637394579015af6b919d3 /dev-ml/ocamlnet
parentdev-ml/ocamlnet: bump to 4.1.4 (diff)
downloadgentoo-86ff62abbee0c7acc3d09f10f9a96fef3403c22b.tar.gz
gentoo-86ff62abbee0c7acc3d09f10f9a96fef3403c22b.tar.bz2
gentoo-86ff62abbee0c7acc3d09f10f9a96fef3403c22b.zip
dev-ml/ocamlnet: cleanup old
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/Manifest1
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-ml/ocamlnet/Manifest b/dev-ml/ocamlnet/Manifest
index fc9215dd9dc1..07c2fea79b5b 100644
--- a/dev-ml/ocamlnet/Manifest
+++ b/dev-ml/ocamlnet/Manifest
@@ -1,3 +1,2 @@
DIST ocamlnet-4.1.2.tar.gz 4623183 BLAKE2B 7e8d5cdc823b9e924258f75f00957ba185d49555377ba2a2d960c47e2ea958059e1ab62e27be63770bb4f547e1fa0cb788a54c3e698180b2b15f0097fe84455a SHA512 69f42042a54efd662db2217224da53513fc7e72c7b2313d4a4a1128f1b4624f4f6298434f5b19f354b832119ff151abc81e85eb0108d6eb24f30f82d176e0b4d
-DIST ocamlnet-4.1.4.tar.gz 4552969 BLAKE2B 3dfedcd09eb91d1ca8e13b7a87dfe70cfb88d57d0b4fa970fe6179affa05ba3fdeaad0dfbb6ac267e7a6530c289408b1a8ad66a805226245f80fe66770addad5 SHA512 ca502444f81898ccda27d61760a357aad59624cf3c4c025d49dd1c2e7bc3ef497c199634247ba7731e016c234e5cd92d2599d1ef9ecd55c3b6e7a64fc4773ee0
DIST ocamlnet-4.1.8.tar.gz 4620065 BLAKE2B 8f84ce4d79de5f4a1f26d4e45f68327042b0adc22717e56eeaca03ee6371e9251c01e8736d3afe5c00a1c65ef0286d56a04c57e80377402bb19ff87955ae98d9 SHA512 e238235968b9546c60568a38e68e354378d30e7137973332dcb10da21fa775ab7b367889fc51f5bd7cb00e51582834cafe2a0c4706b0bc77a44d4571a6f22815
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
deleted file mode 100644
index 1d38ddb0e813..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources strip"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-RDEPEND=">=dev-ml/findlib-1.0
- pcre? ( >=dev-ml/pcre-ocaml-5:= )
- >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- tk? ( dev-ml/labltk:= )
- ssl? ( net-libs/gnutls:= )
- gtk? ( >=dev-ml/lablgtk-2:= )
- kerberos? ( virtual/krb5 )
- zip? ( dev-ml/camlzip:= )
- "
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable ssl gnutls) \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable kerberos gssapi) \
- $(ocamlnet_use_enable pcre pcre) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt
- fi
-}