summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 14:17:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-20 18:32:29 +0200
commitfa8e9f129490b1e143abe39ef5762433c43268e6 (patch)
treeb6d86570bcf4041c8d1de7f24698a48d5996a6da /dev-ml/llvm-ocaml
parentdev-ml/llvm-ocaml: Apply patches in WORKDIR in 10.0.1+ (diff)
downloadgentoo-fa8e9f129490b1e143abe39ef5762433c43268e6.tar.gz
gentoo-fa8e9f129490b1e143abe39ef5762433c43268e6.tar.bz2
gentoo-fa8e9f129490b1e143abe39ef5762433c43268e6.zip
dev-ml/llvm-ocaml: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
index c228684d237c..3b21ac7a774c 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
+inherit cmake llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -53,7 +53,7 @@ src_prepare() {
# cmake eclasses suck by forcing ${S} here
CMAKE_USE_DIR=${S} \
S=${WORKDIR} \
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -95,7 +95,7 @@ src_configure() {
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
# also: custom rules for OCaml do not work for CPPFLAGS
use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
- cmake-utils_src_configure
+ cmake_src_configure
local llvm_libdir=$(llvm-config --libdir)
# an ugly hack; TODO: figure out a way to pass -L to ocaml...
@@ -111,13 +111,13 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile ocaml_all
+ cmake_build ocaml_all
}
src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-llvm-bindings-ocaml
+ cmake_build check-llvm-bindings-ocaml
}
src_install() {