summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-29 15:54:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-29 16:05:23 +0100
commitfb98e369e7c2021dedc702df37475b29cc5ba9f7 (patch)
tree018aaffba0aaccda9bb1986732dd66df8189ea2f /dev-ml/labltk/labltk-8.06.2.ebuild
parentdev-ml/camlp4: bump to 4.04_p1 (diff)
downloadgentoo-fb98e369e7c2021dedc702df37475b29cc5ba9f7.tar.gz
gentoo-fb98e369e7c2021dedc702df37475b29cc5ba9f7.tar.bz2
gentoo-fb98e369e7c2021dedc702df37475b29cc5ba9f7.zip
dev-ml/labltk: bump to 8.06.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ml/labltk/labltk-8.06.2.ebuild')
-rw-r--r--dev-ml/labltk/labltk-8.06.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/labltk/labltk-8.06.2.ebuild b/dev-ml/labltk/labltk-8.06.2.ebuild
new file mode 100644
index 000000000000..fdac48621448
--- /dev/null
+++ b/dev-ml/labltk/labltk-8.06.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
+HOMEPAGE="https://forge.ocamlcore.org/projects/labltk/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1628/${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt X"
+
+RDEPEND=">=dev-lang/tk-8.0.3:=
+ >=dev-lang/ocaml-4.04:=[ocamlopt?,X?]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5.5-r1"
+
+src_prepare() {
+ epatch "${FILESDIR}/findlib.patch"
+}
+
+src_configure() {
+ ./configure --use-findlib --verbose $(use X || echo "--tk-no-x11") || die "configure failed!"
+}
+
+src_compile() {
+ emake -j1
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake \
+ INSTALLDIR="${D}$(ocamlc -where)/labltk" \
+ INSTALLBINDIR="${ED}/usr/bin/" \
+ install
+ dodoc Changes README.mlTk
+}