summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-07-25 20:43:37 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-07-25 20:43:37 +0200
commitb9d5d9070503414e7e4506d9097a8ba1355fd8f2 (patch)
tree715761df96eadbb7ff3bea9472d93bfa83832ddd /dev-ml/dune/dune-1.7.2.ebuild
parentdev-libs/libpqxx: stable 6.4.5 for sparc, bug #690578 (diff)
downloadgentoo-b9d5d9070503414e7e4506d9097a8ba1355fd8f2.tar.gz
gentoo-b9d5d9070503414e7e4506d9097a8ba1355fd8f2.tar.bz2
gentoo-b9d5d9070503414e7e4506d9097a8ba1355fd8f2.zip
dev-ml/dune: add dev-ml/dune
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ml/dune/dune-1.7.2.ebuild')
-rw-r--r--dev-ml/dune/dune-1.7.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/dune/dune-1.7.2.ebuild b/dev-ml/dune/dune-1.7.2.ebuild
new file mode 100644
index 000000000000..f771167311a4
--- /dev/null
+++ b/dev-ml/dune/dune-1.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/1.7.2.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}
+ !dev-ml/jbuilder"
+BDEPEND=""
+
+RESTRICT="test"
+
+src_configure() {
+ ocaml configure.ml --libdir "${EPREFIX}/usr/$(get_libdir)/ocaml" || die
+}
+
+src_compile() {
+ ocaml bootstrap.ml || die
+ ./boot.exe -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ default
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF}
+ mv "${D}"/usr/man "${D}"/usr/share/man
+}