summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-09-28 16:33:02 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-09-28 16:33:02 +0200
commit47243269130c8774f780c3cdb6fae09dbeb8c689 (patch)
tree048717f00c7b2134aaeedb4113473306487f9da7 /dev-ml/dune-private-libs
parentdev-ml/dune-private-libs: required pp is not stable (diff)
downloadgentoo-47243269130c8774f780c3cdb6fae09dbeb8c689.tar.gz
gentoo-47243269130c8774f780c3cdb6fae09dbeb8c689.tar.bz2
gentoo-47243269130c8774f780c3cdb6fae09dbeb8c689.zip
dev-ml/dune-private-libs: rm vendored pp
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dune-private-libs')
-rw-r--r--dev-ml/dune-private-libs/dune-private-libs-3.16.0-r5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/dune-private-libs/dune-private-libs-3.16.0-r5.ebuild b/dev-ml/dune-private-libs/dune-private-libs-3.16.0-r5.ebuild
new file mode 100644
index 000000000000..5a3292540d63
--- /dev/null
+++ b/dev-ml/dune-private-libs/dune-private-libs-3.16.0-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Private libraries of Dune"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.12"
+DEPEND="
+ dev-ml/csexp:=[ocamlopt?]
+ >=dev-ml/pp-1.2.0:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}
+ !dev-ml/stdune
+ !dev-ml/dyn
+ !dev-ml/ordering
+"
+
+src_prepare() {
+ default
+
+ rm -r vendor/{csexp,pp} || die
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ordering dyn stdune ${PN}
+}
+
+src_install() {
+ dune-install ordering dyn stdune ${PN}
+}