summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Kitover <rkitover@gmail.com>2020-04-20 00:21:20 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-05-05 11:46:35 +0300
commit05f8053ee47fb207421205cb98570a4ee8b4990e (patch)
tree33874b6ad5787d6287af13946c7a4c41420430b7 /dev-ml/camlp4
parentnet-im/bitlbee: remove unnecessary chown from pkg_postinst phase (diff)
downloadgentoo-05f8053ee47fb207421205cb98570a4ee8b4990e.tar.gz
gentoo-05f8053ee47fb207421205cb98570a4ee8b4990e.tar.bz2
gentoo-05f8053ee47fb207421205cb98570a4ee8b4990e.zip
dev-ml/camlp4: Avoid stack overflow in build.
Add ulimit -s 11530000 (set stack limit to 11GiB) to src_compile() to try to avoid stack overflow errors. Closes: https://bugs.gentoo.org/644352 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Rafael Kitover <rkitover@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15433 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-ml/camlp4')
-rw-r--r--dev-ml/camlp4/camlp4-4.04_p1.ebuild2
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1.ebuild2
-rw-r--r--dev-ml/camlp4/camlp4-4.08_p1.ebuild4
3 files changed, 7 insertions, 1 deletions
diff --git a/dev-ml/camlp4/camlp4-4.04_p1.ebuild b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
index 8bf8d05f279c..af8352a49da7 100644
--- a/dev-ml/camlp4/camlp4-4.04_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
@@ -33,6 +33,8 @@ src_configure() {
}
src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
emake byte
use ocamlopt && emake native
}
diff --git a/dev-ml/camlp4/camlp4-4.05_p1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
index fe6e0dc150a5..c7ad55154b10 100644
--- a/dev-ml/camlp4/camlp4-4.05_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
@@ -33,6 +33,8 @@ src_configure() {
}
src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
emake byte
use ocamlopt && emake native
}
diff --git a/dev-ml/camlp4/camlp4-4.08_p1.ebuild b/dev-ml/camlp4/camlp4-4.08_p1.ebuild
index 0c86d665428c..731b5432fd93 100644
--- a/dev-ml/camlp4/camlp4-4.08_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.08_p1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,8 @@ src_configure() {
}
src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
emake byte
use ocamlopt && emake native
}