summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:20:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:51 +0200
commitb9cae2b66f0d66355fe3b13c0889269551e2aa00 (patch)
tree317435500c2e15d20748449a02cc9bfaec71cd0e /dev-ml/async_extra/async_extra-0.9.0.ebuild
parentdev-ml/async_rpc_kernel: Bump to 0.9.0 (diff)
downloadgentoo-b9cae2b66f0d66355fe3b13c0889269551e2aa00.tar.gz
gentoo-b9cae2b66f0d66355fe3b13c0889269551e2aa00.tar.bz2
gentoo-b9cae2b66f0d66355fe3b13c0889269551e2aa00.zip
dev-ml/async_extra: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/async_extra/async_extra-0.9.0.ebuild')
-rw-r--r--dev-ml/async_extra/async_extra-0.9.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/async_extra/async_extra-0.9.0.ebuild b/dev-ml/async_extra/async_extra-0.9.0.ebuild
new file mode 100644
index 000000000000..06c9100af230
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="https://github.com/janestreet/async_extra"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-4.02.0:=
+ dev-ml/async_kernel:=
+ dev-ml/async_rpc_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}