summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-24 19:00:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:40:17 +0100
commitfe3feaafd4807bd64c56f802fcb1814128b0b867 (patch)
treeb193bc1faf029320c8f01fa1bad5d76516e814ad /dev-lua
parentdev-lua/lua-term: drop old version (diff)
downloadgentoo-fe3feaafd4807bd64c56f802fcb1814128b0b867.tar.gz
gentoo-fe3feaafd4807bd64c56f802fcb1814128b0b867.tar.bz2
gentoo-fe3feaafd4807bd64c56f802fcb1814128b0b867.zip
dev-lua/lua-utf8: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-utf8/lua-utf8-0.1.3.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-lua/lua-utf8/lua-utf8-0.1.3.ebuild b/dev-lua/lua-utf8/lua-utf8-0.1.3.ebuild
deleted file mode 100644
index 71e19b9f460a..000000000000
--- a/dev-lua/lua-utf8/lua-utf8-0.1.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="A UTF-8 support module for Lua and LuaJIT"
-HOMEPAGE="https://github.com/starwing/luautf8"
-SRC_URI="https://github.com/starwing/luautf8/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN//-/}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="luajit test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- luajit? ( dev-lang/luajit:2 )
- !luajit? ( >=dev-lang/lua-5.1:0= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_compile() {
- local compiler=(
- "$(tc-getCC)"
- "${CFLAGS}"
- "-fPIC"
- "${LDFLAGS}"
- "-I/usr/include"
- "-c lutf8lib.c"
- "-o lutf8lib.o"
- )
- einfo "${compiler[@]}"
- ${compiler[@]} || die
-
- local linker=(
- "$(tc-getCC)"
- "-shared"
- "${LDFLAGS}"
- "-o lutf8lib.so"
- "lutf8lib.o"
- )
- einfo "${linker[@]}"
- ${linker[@]} || die
-}
-
-src_test() {
- local mytests=(
- "test.lua"
- "test_compat.lua"
- "test_pm.lua"
- )
-
- for mytest in ${mytests[@]}; do
- LUA_CPATH="${S}/lutf8lib.so" $(usex luajit 'luajit' 'lua') ${mytest} || die
- done
-}
-
-src_install() {
- exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"
- newexe "lutf8lib.so" "lua-utf8.so"
-
- insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
- doins parseucd.lua
-
- einstalldocs
-}