summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-08-27 16:58:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-08-27 16:58:47 +0200
commite0537a8384ac003d4aa33a130192c2c17f145ba1 (patch)
treef1426adf86061f03bcc5e4f821c2c6c25bb92817 /dev-lua
parentapp-misc/logiops: drop 0.3.1, 0.3.2 (diff)
downloadgentoo-e0537a8384ac003d4aa33a130192c2c17f145ba1.tar.gz
gentoo-e0537a8384ac003d4aa33a130192c2c17f145ba1.tar.bz2
gentoo-e0537a8384ac003d4aa33a130192c2c17f145ba1.zip
dev-lua/lanes: add 3.16.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lanes/Manifest1
-rw-r--r--dev-lua/lanes/lanes-3.16.2.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-lua/lanes/Manifest b/dev-lua/lanes/Manifest
index e114d4b48f66..efad6c323f68 100644
--- a/dev-lua/lanes/Manifest
+++ b/dev-lua/lanes/Manifest
@@ -1,2 +1,3 @@
DIST lanes-3.16.0.tar.gz 257945 BLAKE2B aecc0bd551f10b29791acdde8da30fb83591395eac4d152999a0e92fe9738a6171b13363edae2d94b1db47398a01e011833ccee7a7f234033d3230605423c0b6 SHA512 ffd935baae8af752591251bbb1a7f936034ad281870d453e6e1b4291c175c91537ccae23ec25a616b45e8ab601222f323e05e938d7887091ba7e132b0cd5e449
DIST lanes-3.16.1.tar.gz 446136 BLAKE2B e9505db907660378eb2e67f674a9e671c9554d7587ddeedca6ecaf332cdd03985d027ae5dfa7ae510da9c710b2dc70246e4eb42812347068536dd070a396e20b SHA512 bbc4e7d4dccb10a25f7560dbc4980e36b8f6bb0fbce667471d0be0ad028afc7e1dc88810e78be52a3aee9846512ec10a5ddd324dbe53f9a1db9af647f959014e
+DIST lanes-3.16.2.tar.gz 446113 BLAKE2B 5343ac98f2fac3c92d8afeb6dbbd4875ce93c44715b40b030cbbb03f311b3e358358c1daa295790b0a62113bb15355fc8927a8b7896af079d8e7fe50e2e6b438 SHA512 c7e8037d6f709b31bdb981cbcf70ba51f23823bac51f7ee9ef47881603547a8e1df3c6b7fa35110528cb7547f83048cbe71868aa94c03a59165f1b9d2d5ad08a
diff --git a/dev-lua/lanes/lanes-3.16.2.ebuild b/dev-lua/lanes/lanes-3.16.2.ebuild
new file mode 100644
index 000000000000..42af43b2d1d9
--- /dev/null
+++ b/dev-lua/lanes/lanes-3.16.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lightweight, native, lazy evaluating multithreading library"
+HOMEPAGE="https://github.com/LuaLanes/lanes"
+SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Tests are currently somehow problematic.
+# https://github.com/LuaLanes/lanes/issues/197
+# https://github.com/LuaLanes/lanes/issues/198
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+PATCHES=( "${FILESDIR}/${PN}-3.13.0-makefile.patch" )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LUA=${ELUA}"
+ "LUA_FLAGS=$(lua_get_CFLAGS)"
+ "LUA_LIBS="
+ "OPT_FLAGS=${CFLAGS}"
+ )
+
+ tc-export PKG_CONFIG
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+
+ emake LUA="${ELUA}" test
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ "LUA_SHAREDIR=${ED}/$(lua_get_lmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}