summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:28:48 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:46 +0100
commit87e0efb033b2ac4a78e97d13c299f68647fa0f68 (patch)
treefb30c61e71ffb6393c7fdad08d122b3dedf62698 /dev-lua
parentdev-lua/luaevent: update EAPI 7 -> 8 (diff)
downloadgentoo-87e0efb033b2ac4a78e97d13c299f68647fa0f68.tar.gz
gentoo-87e0efb033b2ac4a78e97d13c299f68647fa0f68.tar.bz2
gentoo-87e0efb033b2ac4a78e97d13c299f68647fa0f68.zip
dev-lua/luaevent: drop 0.4.6-r100
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaevent/luaevent-0.4.6-r100.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild b/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild
deleted file mode 100644
index ae903f070991..000000000000
--- a/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Binding of libevent for Lua"
-HOMEPAGE="http://luaforge.net/projects/luaevent"
-SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- ${LUA_DEPS}
- dev-libs/libevent:0=
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- local mysedargs=(
- -e "'s/CFLAGS =/CFLAGS +=/'"
- -e "'s/LDFLAGS =/LDFLAGS +=/'"
- -e "'s:-I\$(LUA_INC_DIR):\$(LUA_INC_DIR):'"
- -i Makefile
- )
-
- eval sed ${mysedargs[@]} || die
-}
-
-lua_src_compile() {
- tc-export CC
-
- emake LUA_INC_DIR="$(lua_get_CFLAGS)"
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- local myemakeargs=(
- DESTDIR="${ED}"
- INSTALL_DIR_BIN="$(lua_get_cmod_dir)"
- INSTALL_DIR_LUA="$(lua_get_lmod_dir)"
- LUA_INC_DIR="$(lua_get_CFLAGS)"
- )
-
- emake ${myemakeargs[@]} install
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-}