summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-09-26 00:26:54 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-09-26 01:11:43 +0200
commit54c8f012254b36ba8b18e3868791306598dcdd83 (patch)
tree503abcd263f504c77cc180acda25b8ea78710192 /dev-lua
parentdev-lua/busted: stable all-arches (diff)
downloadgentoo-54c8f012254b36ba8b18e3868791306598dcdd83.tar.gz
gentoo-54c8f012254b36ba8b18e3868791306598dcdd83.tar.bz2
gentoo-54c8f012254b36ba8b18e3868791306598dcdd83.zip
dev-lua/busted: drop 2.0.0-r1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/busted/Manifest1
-rw-r--r--dev-lua/busted/busted-2.0.0-r1.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-lua/busted/Manifest b/dev-lua/busted/Manifest
index 37e6ec7016f0..5451f6c9f54f 100644
--- a/dev-lua/busted/Manifest
+++ b/dev-lua/busted/Manifest
@@ -1,2 +1 @@
-DIST busted-2.0.0.tar.gz 55002 BLAKE2B 39a3b7bf156911e25f94020f9e56b3f43b9f02b910a9d1c1f288dbdb83e5d53253d5b40d73df655844ed683cff7959d42c330c0d061db918385df07870e16da3 SHA512 3151694b1fba1acc52e3bcfee0231008b14934e89da5885d7e063c6f023479c42040c42a8c0aa6ff1f8303ad6b2a70f0687c8a218830de7231007ef8748457bf
DIST busted-2.1.1.tar.gz 62594 BLAKE2B 3afd49dd70b27243e32f69d5d5a0a0ee13e46fdbe46fe6921e1b854abddaa45dba098f19c5994d5656eca871beacd654cac20abe0662c21f6e7efaff19984753 SHA512 80a362094398b85f2783ca11adfae1f7ead38b9de7d11d2c2f8234f2d8f1289dc853f58c11c375b8edd6ea87807a65cc8bce01ebcf7cdf75701796ee528a75a0
diff --git a/dev-lua/busted/busted-2.0.0-r1.ebuild b/dev-lua/busted/busted-2.0.0-r1.ebuild
deleted file mode 100644
index 4a11ad485569..000000000000
--- a/dev-lua/busted/busted-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua
-
-DESCRIPTION="Elegant Lua unit testing"
-HOMEPAGE="https://lunarmodules.github.io/busted/"
-SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- dev-lua/luafilesystem[${LUA_USEDEP}]
- dev-lua/luasystem[${LUA_USEDEP}]
- dev-lua/dkjson[${LUA_USEDEP}]
- dev-lua/say[${LUA_USEDEP}]
- dev-lua/luassert[${LUA_USEDEP}]
- dev-lua/lua-term[${LUA_USEDEP}]
- dev-lua/penlight[${LUA_USEDEP}]
- dev-lua/mediator_lua[${LUA_USEDEP}]
- ${LUA_DEPS}
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted
- ${RDEPEND}
- )
-"
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)
- doins -r busted
-}
-
-src_install() {
- dobin bin/busted
-
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}