summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-06-23 23:54:52 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-06-24 23:35:40 +0200
commit4b7d0ad69bec51fff48dc96b34716ad9468ffe3e (patch)
treea6ff9565d9886348d1738fb7e21b7910b2a2ae79 /dev-lua
parentdev-lua/luacheck: add 1.1.1 (diff)
downloadgentoo-4b7d0ad69bec51fff48dc96b34716ad9468ffe3e.tar.gz
gentoo-4b7d0ad69bec51fff48dc96b34716ad9468ffe3e.tar.bz2
gentoo-4b7d0ad69bec51fff48dc96b34716ad9468ffe3e.zip
dev-lua/luaposix: add 36.2.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaposix/Manifest1
-rw-r--r--dev-lua/luaposix/luaposix-36.2.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-lua/luaposix/Manifest b/dev-lua/luaposix/Manifest
index e012c924385a..118519731c5d 100644
--- a/dev-lua/luaposix/Manifest
+++ b/dev-lua/luaposix/Manifest
@@ -1 +1,2 @@
DIST luaposix-36.1.tar.gz 186075 BLAKE2B 209b27c575d664143e565443b3c0a46437a41f77e78729fdd08258a98247d82ffc6a31031f01d70bd545418ec678c0af8a24e6b14ed34694fc46d9420b3a687d SHA512 7a15725cec3701a26d1a25da3b8320ab0a9a4a3f6ee64dd0263bf0aec763bc21940c13fed58bd6a93f60eb07cd44288fa18ec26c63c32138846229515b8f3596
+DIST luaposix-36.2.1.tar.gz 188010 BLAKE2B 7f1d3cf0d766e32433f4946be92f3f0036652ae09e4816c8423e65ce47237b20151fec8ffa3d4b32079b247a98cb79f9c35758aff3c56c116b903a3b44c2c550 SHA512 cd7deeaa9179306f90bafdc6cfb2668cf42d5378e72e5baa09419198f2d42c5eab5d881e5584ac511f317bbfd850f2ad46b8cb743f1ae5e1a96f8153e03599d8
diff --git a/dev-lua/luaposix/luaposix-36.2.1.ebuild b/dev-lua/luaposix/luaposix-36.2.1.ebuild
new file mode 100644
index 000000000000..c135178d9d85
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-36.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+IUSE="doc"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Requires specl, which is not in the tree yet
+RESTRICT="test"
+
+DEPEND="${LUA_DEPS}
+ virtual/libcrypt:=
+"
+RDEPEND="${DEPEND}
+ lua_targets_lua5-1? ( dev-lua/lua-bit32[lua_targets_lua5-1(-)] )
+ lua_targets_luajit? ( dev-lua/lua-bit32[lua_targets_luajit(-)] )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ # LDOC=true means disable ldoc update documentation
+ ./build-aux/luke --verbose package="${PN}" version="${PV}" \
+ LDOC=true \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ LUA_INCDIR="${EPREFIX}/$(lua_get_include_dir)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+
+ popd || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ ./build-aux/luke install \
+ LDOC=true \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$(lua_get_cmod_dir)" \
+ INST_LUADIR="${ED}/$(lua_get_lmod_dir)" \
+ || die
+
+ popd || die
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ dodoc {NEWS,README}.md
+ use doc && dodoc -r doc
+}