summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-04 21:23:43 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-04 22:33:44 +0200
commit2a21f085e0b2218a6f690416426017a1133fa40f (patch)
tree28fb834295f71d76dfd48de5fa4b628747b64266 /dev-lua
parentsys-fs/cryptmount: drop 5.3.3-r2 (diff)
downloadgentoo-2a21f085e0b2218a6f690416426017a1133fa40f.tar.gz
gentoo-2a21f085e0b2218a6f690416426017a1133fa40f.tar.bz2
gentoo-2a21f085e0b2218a6f690416426017a1133fa40f.zip
dev-lua/lua-utf8: add 0.1.4
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-utf8/Manifest1
-rw-r--r--dev-lua/lua-utf8/lua-utf8-0.1.4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-lua/lua-utf8/Manifest b/dev-lua/lua-utf8/Manifest
index 922b02768582..955d2981cc6e 100644
--- a/dev-lua/lua-utf8/Manifest
+++ b/dev-lua/lua-utf8/Manifest
@@ -1 +1,2 @@
DIST lua-utf8-0.1.3.tar.gz 41830 BLAKE2B 72982c7ec8d8837e391fa6bfb689c1e9f4a7746d0cbc058556f06027b4af00c936036f87baf58f45e1169fd3ea7e6d8174629d5a7279205622cf0710971ca29c SHA512 d0abe73fecbfeba36083c135d77962d953ad9e431721a2557669c912a2703e31c46f84f2ee9ee4ac966a5bcc88d4daef930f8d2d8e72106fa61010509c183e29
+DIST lua-utf8-0.1.4.tar.gz 42822 BLAKE2B e9b2e46de28183b7e249d02af343707f06ba2d04df29ad0596823faa01c9e885a0cc71581dcc3b98807bae00b7491215ffcf9082a8ac0cc5f5bc558e2e48d113 SHA512 8893e4883a6eae791c7728a235c0447850ef753edb19c268c2b88ad9f5b9c485bae733afc712beff956a77ab64f7074633fc5d96ea4bb14e8c8f87e9e0ea3363
diff --git a/dev-lua/lua-utf8/lua-utf8-0.1.4.ebuild b/dev-lua/lua-utf8/lua-utf8-0.1.4.ebuild
new file mode 100644
index 000000000000..34527a96652f
--- /dev/null
+++ b/dev-lua/lua-utf8/lua-utf8-0.1.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A UTF-8 support module for Lua and LuaJIT"
+HOMEPAGE="https://github.com/starwing/luautf8"
+SRC_URI="https://github.com/starwing/luautf8/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_compile() {
+ local compiler=(
+ "$(tc-getCC)"
+ "${CFLAGS}"
+ "-fPIC"
+ "${LDFLAGS}"
+ "$(lua_get_CFLAGS)"
+ "-c lutf8lib.c"
+ "-o lutf8lib-${ELUA}.o"
+ )
+ einfo "${compiler[@]}"
+ ${compiler[@]} || die
+
+ local linker=(
+ "$(tc-getCC)"
+ "-shared"
+ "${LDFLAGS}"
+ "-o lutf8lib-${ELUA}.so"
+ "lutf8lib-${ELUA}.o"
+ )
+ einfo "${linker[@]}"
+ ${linker[@]} || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ local mytests=(
+ "test.lua"
+ "test_compat.lua"
+ "test_pm.lua"
+ )
+
+ for mytest in ${mytests[@]}; do
+ LUA_CPATH="${S}/lutf8lib-${ELUA}.so" ${ELUA} ${mytest} || die
+ done
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ exeinto "$(lua_get_cmod_dir)"
+ newexe "lutf8lib-${ELUA}.so" "lua-utf8.so"
+
+ insinto "$(lua_get_lmod_dir)"
+ doins parseucd.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}