summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-12 01:08:30 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-12 01:10:03 +0200
commit19a953464725d83207324fc51b947f3bf770a99c (patch)
treebe05af318f0523d42d94b203fbfcf83b666c590d /dev-lua
parentdev-lua/luaossl: add 20220711 (diff)
downloadgentoo-19a953464725d83207324fc51b947f3bf770a99c.tar.gz
gentoo-19a953464725d83207324fc51b947f3bf770a99c.tar.bz2
gentoo-19a953464725d83207324fc51b947f3bf770a99c.zip
dev-lua/luaossl: drop 20220711
Closes: https://bugs.gentoo.org/805041 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaossl/Manifest1
-rw-r--r--dev-lua/luaossl/luaossl-20220711.ebuild97
2 files changed, 0 insertions, 98 deletions
diff --git a/dev-lua/luaossl/Manifest b/dev-lua/luaossl/Manifest
index 0242e7046364..db230bd70a4e 100644
--- a/dev-lua/luaossl/Manifest
+++ b/dev-lua/luaossl/Manifest
@@ -1,2 +1 @@
DIST luaossl-rel-20200709.tar.gz 352960 BLAKE2B f4cd53937d7a9c724ab9f2f6a13f1da8fa54216f01fe2af7e65cf7ebdad1f8740491ba1fc6bcc2bf4ac377bde0d2e370433e76a5105c6226e0d9745e12bec0ea SHA512 324175f65e9d292ecb1343cfa9e111f1fd17f15e67037bd705d3db95d32b859c039a6e70620d649f446a8e7043a125a75c64de1714f0fe18e077fb9c017bea34
-DIST luaossl-rel-20220711.tar.gz 505174 BLAKE2B be8736c9198c2c602ab4495f5498e96c90c66ac2712c4c299e3279fa5acd9168fcac29730f1db000eb908ca5f0a2215856c75bbd4a2cf3927cbdf82615160467 SHA512 13c51881218a5a9995d195d4781f6871f0dfe58f061b85dd997b98ec970a38302ac6b057b7987bff5f7719bfdb826aae09f602ea8db5e4b2d462648ad0236909
diff --git a/dev-lua/luaossl/luaossl-20220711.ebuild b/dev-lua/luaossl/luaossl-20220711.ebuild
deleted file mode 100644
index 0cbaf9a0b4ed..000000000000
--- a/dev-lua/luaossl/luaossl-20220711.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-MY_P="${PN}-rel-${PV}"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Most comprehensive OpenSSL module in the Lua universe"
-HOMEPAGE="https://github.com/wahern/luaossl"
-SRC_URI="https://github.com/wahern/${PN}/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="examples"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/openssl:0=[-bindist(-)]
- !dev-lua/lua-openssl
- !dev-lua/luasec
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "doc/." )
-
-src_prepare() {
- default
-
- # Remove Lua autodetection
- # Respect users CFLAGS
- sed -e '/LUAPATH :=/d' -e '/LUAPATH_FN =/d' -e '/HAVE_API_FN =/d' -e '/WITH_API_FN/d' -e 's/-O2//g' -i GNUmakefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- if [[ ${ELUA} != luajit ]]; then
- LUA_VERSION="$(ver_cut 1-2 $(lua_get_version))"
- else
- # This is a workaround for luajit, as it confirms to lua5.1
- # and the 'GNUmakefile' doesn't understand LuaJITs version.
- LUA_VERSION="5.1"
- fi
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "ALL_CPPFLAGS=${CPPFLAGS} $(lua_get_CFLAGS)"
- "libdir="
- )
-
- emake "${myemakeargs[@]}" openssl${LUA_VERSION}
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- if [[ ${ELUA} != luajit ]]; then
- LUA_VERSION="$(ver_cut 1-2 $(lua_get_version))"
- else
- # This is a workaround for luajit, as it confirms to lua5.1
- # and the 'GNUmakefile' doesn't understand LuaJITs version.
- LUA_VERSION="5.1"
- fi
-
- local myemakeargs=(
- "DESTDIR=${D}"
- "lua${LUA_VERSION/./}cpath=$(lua_get_cmod_dir)"
- "lua${LUA_VERSION/./}path=$(lua_get_lmod_dir)"
- "prefix=${EPREFIX}/usr"
- )
-
- emake "${myemakeargs[@]}" install${LUA_VERSION}
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- use examples && dodoc -r "examples/."
- einstalldocs
-}