summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-11-05 18:31:27 -0600
committerWilliam Hubbs <williamh@gentoo.org>2015-11-05 18:33:16 -0600
commitd331b133dad3196327c55cc14c6daf08e43f1d02 (patch)
tree747157c03aa3ae7c3140f551ee929fcf1dc01054 /dev-lua/luacov/luacov-0.8.ebuild
parentdev-db/percona-server: Add patch for tests and update test instructions (diff)
downloadgentoo-d331b133dad3196327c55cc14c6daf08e43f1d02.tar.gz
gentoo-d331b133dad3196327c55cc14c6daf08e43f1d02.tar.bz2
gentoo-d331b133dad3196327c55cc14c6daf08e43f1d02.zip
dev-lua/luacov: initial commit
Diffstat (limited to 'dev-lua/luacov/luacov-0.8.ebuild')
-rw-r--r--dev-lua/luacov/luacov-0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lua/luacov/luacov-0.8.ebuild b/dev-lua/luacov/luacov-0.8.ebuild
new file mode 100644
index 000000000000..d1fd6c10266d
--- /dev/null
+++ b/dev-lua/luacov/luacov-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="LuaCov is a simple coverage analyzer for Lua scripts"
+HOMEPAGE="https://github.com/keplerproject/luacov"
+SRC_URI="https://github.com/keplerproject/luacov/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1"
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-fix-makefile.patch
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ PREFIX=/usr \
+ LUADIR="$(pkg-config --variable INSTALL_LMOD lua)" install
+dohtml -r doc/*
+ dodoc -r examples
+}