summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-14 12:46:30 +0200
committerSam James <sam@gentoo.org>2022-07-15 02:35:18 +0100
commit4dd244f9f422fa38ad88b4954de5b0b9535c2d06 (patch)
tree830b974e42c44981ed754de4b9b493b7a0d754a5 /dev-lisp
parentgames-strategy/augustus: Fix build on musl (diff)
downloadgentoo-4dd244f9f422fa38ad88b4954de5b0b9535c2d06.tar.gz
gentoo-4dd244f9f422fa38ad88b4954de5b0b9535c2d06.tar.bz2
gentoo-4dd244f9f422fa38ad88b4954de5b0b9535c2d06.zip
dev-lisp/abcl: add 1.9.0
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26400 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/abcl/Manifest1
-rw-r--r--dev-lisp/abcl/abcl-1.9.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-lisp/abcl/Manifest b/dev-lisp/abcl/Manifest
index 3a6809ee6e64..273a6c5fd489 100644
--- a/dev-lisp/abcl/Manifest
+++ b/dev-lisp/abcl/Manifest
@@ -1 +1,2 @@
DIST abcl-src-1.8.0.tar.gz 2613411 BLAKE2B cd50e5df0b7e48c902bc904ca4ea0e9c293241e04cfda154cb388c5f58da921645333fca8e0a95768a550fcb2a5b6346b3e8958745138ea6826f5c5a62ef0faf SHA512 90cc2d1e52a4dc83a0159a5763d2c7eb344952786a805a82180e0000a0cae26d89ae5a9293b629b7b5131eac05668fe21711abca32aebe05d7400187b0b3793b
+DIST abcl-src-1.9.0.tar.gz 2470791 BLAKE2B e6c79a7f9dc94fe978c81f0752774b54b850c3019eb40a66cb043e6463ae6aa80b8e09d628847017335cf077029f6548be40394adf06a8549609b5bb7cb26dd1 SHA512 d061565a4e89fd11238118fccf72ea212b9bc87c708f89f13e8e9564d984ee405a189b93fd904ecae7b7f6663ca130b5c7ab774f7f9fd31282708c639e3ef9f6
diff --git a/dev-lisp/abcl/abcl-1.9.0.ebuild b/dev-lisp/abcl/abcl-1.9.0.ebuild
new file mode 100644
index 000000000000..044985795141
--- /dev/null
+++ b/dev-lisp/abcl/abcl-1.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM"
+HOMEPAGE="https://abcl.org"
+SRC_URI="https://abcl.org/releases/${PV}/abcl-src-${PV}.tar.gz"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/abcl-src-${PV}"
+
+src_compile() {
+ eant abcl.compile
+ eant abcl.jar || die "Can't make ABCL jar archive"
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+ dodoc README
+}