summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-17 22:09:27 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-17 22:12:24 +0200
commite45260b7eaec7480f56578a66e59fed830132c1d (patch)
treed98103d8c762a85ccfd8480baf70ba7661927060 /dev-lisp/gcl
parentmedia-libs/libvpx: fix UnusedLocalUse (diff)
downloadgentoo-e45260b7eaec7480f56578a66e59fed830132c1d.tar.gz
gentoo-e45260b7eaec7480f56578a66e59fed830132c1d.tar.bz2
gentoo-e45260b7eaec7480f56578a66e59fed830132c1d.zip
dev-lisp/gcl: Remove old
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp/gcl')
-rw-r--r--dev-lisp/gcl/Manifest2
-rw-r--r--dev-lisp/gcl/files/gcl-gmp-6.patch8
-rw-r--r--dev-lisp/gcl/files/gcl-readline-6.3.patch18
-rw-r--r--dev-lisp/gcl/files/gcl-tcl-8.6.patch103
-rw-r--r--dev-lisp/gcl/gcl-2.6.10.ebuild149
5 files changed, 0 insertions, 280 deletions
diff --git a/dev-lisp/gcl/Manifest b/dev-lisp/gcl/Manifest
index 38004af63fd9..f52fb79b7298 100644
--- a/dev-lisp/gcl/Manifest
+++ b/dev-lisp/gcl/Manifest
@@ -1,3 +1 @@
-DIST gcl-2.6.10-fedora.tar.bz2 695718 BLAKE2B 151cac372f74a971ffb31191a3614d0f7bafca141258af9e1955185f8ed119cbcd3797f2d9bbe5eb5f82e76af4fd0d3e0cf155cd35f305a2c028e40b340b78cf SHA512 3e0ffaec859783443a8941a29302c7a17c9538ef2177d449ad34e24292c174de7bb8760a6d327e08f012773032f0d0a5230b79c7e4b4f5bad8354bf10a28af4c
-DIST gcl-2.6.10.tar.gz 5490689 BLAKE2B 46af0cf8a810a82fe2bc2bd46ca1cbe17b74c71eb4af6a06032040900dcad4dd4338883cd9225f0945ae425eba788ac84db9a0ed454779edd86c74a1bb48a947 SHA512 bbaacce712f15130550bcdf7e53edf4df9ab955e84ec701087034115df1c1e657d956853d5db85d7e88709981f9b7fd4c9df7acf6c8588a8ccf5f05e4e666aed
DIST gcl-2.6.13_pre99.tar.xz 10030460 BLAKE2B 8750d641062bcad5a124173013d38403f37ad352c7c436e89d4e329d997200be399a100dcefc4ce484e3f85f46e2dd90ee02947e5e728e001782e973c4122b0e SHA512 a3ad2bd639157ca2a80b534e87c169f6e07002a1b9ca8039483cff336af764123dec9e749da045b656b990e0a97c70881c798420ec4bd0e4494f43d0d040e413
diff --git a/dev-lisp/gcl/files/gcl-gmp-6.patch b/dev-lisp/gcl/files/gcl-gmp-6.patch
deleted file mode 100644
index f66638478af1..000000000000
--- a/dev-lisp/gcl/files/gcl-gmp-6.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff -r -U1 gcl.orig/configure gcl/configure
---- gcl.orig/configure 2013-11-11 21:55:48.000000000 +0700
-+++ gcl/configure 2014-03-30 17:25:04.874994142 +0700
-@@ -5027,3 +5027,3 @@
- int main() {
-- #if __GNU_MP_VERSION == 4 || __GNU_MP_VERSION == 5
-+ #if __GNU_MP_VERSION == 4 || __GNU_MP_VERSION == 5 || __GNU_MP_VERSION == 6
- return 0;
diff --git a/dev-lisp/gcl/files/gcl-readline-6.3.patch b/dev-lisp/gcl/files/gcl-readline-6.3.patch
deleted file mode 100644
index 063c772f1051..000000000000
--- a/dev-lisp/gcl/files/gcl-readline-6.3.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -r -U1 gcl.orig/o/gcl_readline.d gcl/o/gcl_readline.d
---- gcl.orig/o/gcl_readline.d 2013-11-11 21:55:48.000000000 +0700
-+++ gcl/o/gcl_readline.d 2014-03-30 18:29:42.131967005 +0700
-@@ -53,2 +53,9 @@
-
-+/* Deprecated CPPFunction disappeared in libreadline-6.3 */
-+#if defined(_RL_FUNCTION_TYPEDEF)
-+#define RL_COMPLETION_FUNC_T rl_completion_func_t
-+#else
-+#define RL_COMPLETION_FUNC_T CPPFunction
-+#endif
-+
- int readline_on = 0; /* On (1) or off (0) */
-@@ -471,3 +478,3 @@
- #ifdef RL_COMPLETION
-- rl_attempted_completion_function = (CPPFunction *)rl_completion;
-+ rl_attempted_completion_function = (RL_COMPLETION_FUNC_T *)rl_completion;
- #endif
diff --git a/dev-lisp/gcl/files/gcl-tcl-8.6.patch b/dev-lisp/gcl/files/gcl-tcl-8.6.patch
deleted file mode 100644
index cfbf82e32899..000000000000
--- a/dev-lisp/gcl/files/gcl-tcl-8.6.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-diff --git a/gcl/gcl-tk/tkMain.c b/gcl/gcl-tk/tkMain.c
-index 74475cc..21c6c59 100755
---- a/gcl/gcl-tk/tkMain.c
-+++ b/gcl/gcl-tk/tkMain.c
-@@ -42,6 +42,11 @@
- #if (TK_MINOR_VERSION==0 && TK_MAJOR_VERSION==4)
- #define TkCreateMainWindow Tk_CreateMainWindow
- #endif
-+#if TCL_MAJOR_VERSION >= 8
-+#define INTERP_RESULT(interp) Tcl_GetStringResult(interp)
-+#else
-+#define INTERP_RESULT(interp) (interp)->result
-+#endif
-
-
- /*-------------------------------------------------------------------*/
-@@ -276,7 +281,7 @@ TkX_Wish (argc, argv)
-
- if (Tk_ParseArgv(interp, (Tk_Window) NULL, &argc, (void *)argv, argTable, 0)
- != TCL_OK) {
-- fprintf(stderr, "%s\n", interp->result);
-+ fprintf(stderr, "%s\n", INTERP_RESULT(interp));
- exit(1);
- }
- if (name == NULL) {
-@@ -309,7 +314,7 @@ TkX_Wish (argc, argv)
-
- /* mainWindow = TkCreateMainWindow(interp, display, name/\* , "Tk" *\/); */
- /* if (mainWindow == NULL) { */
--/* fprintf(stderr, "%s\n", interp->result); */
-+/* fprintf(stderr, "%s\n", INTERP_RESULT(interp)); */
- /* exit(1); */
- /* } */
- /* #ifndef __MINGW32__ */
-@@ -362,7 +367,7 @@ TkX_Wish (argc, argv)
- Tcl_FindExecutable ( argv[0] );
- #else
- if (Tcl_AppInit(interp) != TCL_OK) {
-- fprintf(stderr, "Tcl_AppInit failed: %s\n", interp->result);
-+ fprintf(stderr, "Tcl_AppInit failed: %s\n", INTERP_RESULT(interp));
- }
- #endif
- /*
-@@ -372,7 +377,7 @@ TkX_Wish (argc, argv)
- if (geometry != NULL) {
- code = Tcl_VarEval(interp, "wm geometry . ", geometry, (char *) NULL);
- if (code != TCL_OK) {
-- fprintf(stderr, "%s\n", interp->result);
-+ fprintf(stderr, "%s\n", INTERP_RESULT(interp));
- }
- }
-
-@@ -402,13 +407,13 @@ TkX_Wish (argc, argv)
-
- fullName = Tcl_TildeSubst(interp, tcl_RcFileName, &buffer);
- if (fullName == NULL) {
-- fprintf(stderr, "%s\n", interp->result);
-+ fprintf(stderr, "%s\n", INTERP_RESULT(interp));
- } else {
- f = fopen(fullName, "r");
- if (f != NULL) {
- code = Tcl_EvalFile(interp, fullName);
- if (code != TCL_OK) {
-- fprintf(stderr, "%s\n", interp->result);
-+ fprintf(stderr, "%s\n", INTERP_RESULT(interp));
- }
- fclose(f);
- }
-@@ -443,7 +448,7 @@ TkX_Wish (argc, argv)
- error:
- msg = Tcl_GetVar(interp, "errorInfo", TCL_GLOBAL_ONLY);
- if (msg == NULL) {
-- msg = interp->result;
-+ msg = INTERP_RESULT(interp);
- }
- dfprintf(stderr, "%s\n", msg);
- Tcl_Eval(interp, errorExitCmd);
-@@ -566,13 +571,13 @@ StdinProc(clientData, mask)
- || code)
- {
- char buf[4];
-- char *p = buf;
-+ char *p = buf, *string;
- /*header */
- *p++ = (code ? '1' : '0');
- bcopy(msg->msg_id,p,3);
- /* end header */
-- if(sock_write_str2(dsfd, m_reply, buf, 4 ,
-- interp->result, strlen(interp->result))
-+ string = INTERP_RESULT(interp);
-+ if(sock_write_str2(dsfd, m_reply, buf, 4, string, strlen(string))
- < 0)
- { /* what do we want to do if the write failed */}
-
-@@ -752,7 +757,7 @@ guiBindCallback(char *szNameCmdProc, char *szTclObject, char *szModifier,char* a
- code = Tcl_Eval(interp, szCmd);
- if (code != TCL_OK)
- {
-- dfprintf(stderr, "TCL Error int bind : %s\n", interp->result);
-+ dfprintf(stderr, "TCL Error int bind : %s\n", INTERP_RESULT(interp));
-
- }
- return code;
diff --git a/dev-lisp/gcl/gcl-2.6.10.ebuild b/dev-lisp/gcl/gcl-2.6.10.ebuild
deleted file mode 100644
index 47a5f441a32c..000000000000
--- a/dev-lisp/gcl/gcl-2.6.10.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit elisp-common epatch flag-o-matic
-
-DESCRIPTION="GNU Common Lisp"
-HOMEPAGE="https://www.gnu.org/software/gcl/gcl.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz https://dev.gentoo.org/~grozin/${P}-fedora.tar.bz2"
-S="${WORKDIR}"/${PN}
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="+ansi athena emacs +readline tk X"
-
-# See bug #205803
-RESTRICT="strip"
-
-RDEPEND="emacs? ( >=app-editors/emacs-23.1:* )
- readline? ( sys-libs/readline:= )
- athena? ( x11-libs/libXaw )
- >=dev-libs/gmp-4.1:=
- tk? ( dev-lang/tk:= )
- X? ( x11-libs/libXt x11-libs/libXext x11-libs/libXmu x11-libs/libXaw )
- virtual/latex-base"
-DEPEND="${RDEPEND}
- virtual/texi2dvi
- >=app-text/texi2html-1.64
- >=sys-devel/autoconf-2.52"
-
-src_prepare() {
- mv "${WORKDIR}"/fedora/info/* info/
- cp -p /usr/share/texmf-dist/tex/texinfo/texinfo.tex info/
- find . -type f -perm /0111 | xargs chmod a-x
- chmod a+x add-defs add-defs1 config.guess config.sub configure install.sh
- chmod a+x bin/info bin/info1 gcl-tk/gcltksrv.in gcl-tk/ngcltksrv mp/gcclab
- chmod a+x o/egrep-def utils/replace xbin/*
-
- # fedora patches
- epatch "${WORKDIR}"/fedora/fd-leak.patch
- epatch "${WORKDIR}"/fedora/latex.patch
- epatch "${WORKDIR}"/fedora/texinfo.patch
- epatch "${WORKDIR}"/fedora/elisp.patch
- epatch "${WORKDIR}"/fedora/rename.patch
- epatch "${WORKDIR}"/fedora/getcwd.patch
- epatch "${WORKDIR}"/fedora/infrastructure.patch
- epatch "${WORKDIR}"/fedora/extension.patch
- epatch "${WORKDIR}"/fedora/unrandomize.patch
- epatch "${WORKDIR}"/fedora/asm-signal-h.patch
- epatch "${WORKDIR}"/fedora/plt.patch
- epatch "${WORKDIR}"/fedora/ellipsis.patch
- epatch "${WORKDIR}"/fedora/man.patch
- epatch "${WORKDIR}"/fedora/reloc-type.patch
- epatch "${WORKDIR}"/fedora/largefile.patch
-
- epatch "${FILESDIR}"/${PN}-tcl-8.6.patch
- epatch "${FILESDIR}"/${PN}-gmp-6.patch
- epatch "${FILESDIR}"/${PN}-readline-6.3.patch
-
- sed -e 's|"-fomit-frame-pointer"|""|' -i configure
- sed -e 's|@EXT@||g' debian/in.gcl.1 > gcl.1
-}
-
-src_configure() {
- strip-flags
- filter-flags -fstack-protector -fstack-protector-all
-
- local tcl=""
- if use tk; then
- tcl="--enable-tclconfig=/usr/lib --enable-tkconfig=/usr/lib"
- fi
-
- econf --enable-dynsysgmp \
- --disable-xdr \
- --enable-emacsdir=/usr/share/emacs/site-lisp/gcl \
- --enable-infodir=/usr/share/info \
- $(use_enable readline) \
- $(use_enable ansi) \
- $(use_enable athena xgcl) \
- $(use_with X x) \
- ${tcl}
-}
-
-src_compile() {
- emake -j1
- VARTEXFONTS="${T}"/fonts emake -C info gcl.info
- if use athena; then
- pushd xgcl-2 > /dev/null
- pdflatex dwdoc.tex
- popd > /dev/null
- fi
-}
-
-src_test() {
- local make_ansi_tests_clean="rm -f test.out *.fasl *.o *.so *~ *.fn *.x86f *.fasl *.ufsl"
- if use ansi; then
- cd ansi-tests
-
- ( make clean && make test-unixport ) \
- || die "make ansi-tests failed!"
-
- cat "${FILESDIR}/bootstrap-gcl" \
- | ../unixport/saved_ansi_gcl
-
- cat "${FILESDIR}/bootstrap-gcl" \
- |sed s/bootstrapped_ansi_gcl/bootstrapped_r_ansi_gcl/g \
- | ./bootstrapped_ansi_gcl
-
- ( ${make_ansi_tests_clean} && \
- echo "(load \"gclload.lsp\")" \
- | ./bootstrapped_r_ansi_gcl ) \
- || die "Phase 2, bootstraped compiler failed in tests"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- mv "${D}"usr/share/doc/*.dvi .
- rm -rf "${D}"usr/share/doc
- rm -rf "${D}"usr/share/emacs
- rm -rf "${D}"usr/lib/gcl-*/info
-
- rm doc/makefile elisp/add-defaults.el
- dodoc readme* RELEASE* ChangeLog* doc/*
- doman gcl.1
- doinfo info/*.info*
- dohtml -r info/gcl-si info/gcl-tk
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
- elisp-install ${PN} elisp/*.el
- fi
-
- docompress -x /usr/share/doc/${PF}/*.dvi
- if use athena; then
- dodoc xgcl-2/*.pdf
- docompress -x /usr/share/doc/${PF}/*.pdf
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}