summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lisp/abcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lisp/abcl')
-rw-r--r--dev-lisp/abcl/Manifest2
-rw-r--r--dev-lisp/abcl/abcl-0.0.9-r1.ebuild79
-rw-r--r--dev-lisp/abcl/abcl-0.20.0.ebuild35
-rw-r--r--dev-lisp/abcl/metadata.xml15
4 files changed, 131 insertions, 0 deletions
diff --git a/dev-lisp/abcl/Manifest b/dev-lisp/abcl/Manifest
new file mode 100644
index 000000000000..c5acfb12b355
--- /dev/null
+++ b/dev-lisp/abcl/Manifest
@@ -0,0 +1,2 @@
+DIST abcl-0.0.9.tar.gz 592410 SHA256 ee634443a4a77b2bb9324fa4ff900b15aea5081042fde039045b535d28a8049b SHA512 d822f099ab73f1f62f14bfa3991b88573587d90a8c31e97933549bd19fabaa4d9337963ba33f6ef59f65c259f374bbabb5263c2c3fda3d99a19a645756f80a1c WHIRLPOOL dc405429363bb5a06cc49ad2368451048c83a2eb481e8e8b3d0e9659754d4fdaf5d1a98ba93f9aff647c0e82dff71c41f3e3d75023ab6b02c6142f7062163e82
+DIST abcl-src-0.20.0.tar.gz 735614 SHA256 050e9f6eac7714a39fadafcf5a98893a7926322505c564b1d355748e47c06b48 SHA512 73b033883149b1083a03d87ed5c41b5b6e790cb02978a82f1b57274e6744b66c7b05c5a708077f354ee46ce0780327dfc728bbd9cd9c4f87bd69b730ead8e81b WHIRLPOOL a160ff7d436354fd66bfb467a57ffe3b41c6c08a6a1d02b775979d5955470eac15512737d32003b8d6c73428c655f1f33750a65f5288ecdf06bbfe21e52e9fe0
diff --git a/dev-lisp/abcl/abcl-0.0.9-r1.ebuild b/dev-lisp/abcl/abcl-0.0.9-r1.ebuild
new file mode 100644
index 000000000000..8e660c63529f
--- /dev/null
+++ b/dev-lisp/abcl/abcl-0.0.9-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="ABCL is an implementation of ANSI Common Lisp that runs in a Java VM"
+HOMEPAGE="http://armedbear.org/abcl.html"
+SRC_URI="http://armedbear.org/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="jad clisp cmucl"
+
+RDEPEND=">=virtual/jre-1.4
+ jad? ( dev-java/jad-bin )"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-lang/python
+ !cmucl? ( !clisp? ( dev-lisp/sbcl ) )
+ cmucl? ( dev-lisp/cmucl )
+ clisp? ( dev-lisp/clisp )"
+
+src_unpack() {
+ unpack ${A}
+ cat > "${S}/customizations.lisp" <<EOF
+(in-package #:build-abcl)
+(setf
+*javac-options* "-g $(java-pkg_javac-args)"
+*jikes-options* "+D -g $(java-pkg_javac-args)"
+*jdk* "${JAVA_HOME}/"
+*java-compiler* "${JAVAC}"
+*jar* "jar")
+EOF
+ einfo "Building with the following customizations.lisp:"
+ cat "${S}/customizations.lisp"
+ cat >"${S}/build.lisp" <<'EOF'
+(progn (load "build-abcl") (funcall (intern "BUILD-ABCL" "BUILD-ABCL") :clean t :full t) #+sbcl (sb-ext:quit) #+clisp (ext:quit) #+cmu (extensions:quit))
+EOF
+}
+
+getutfvars() {
+python << EOF
+import os
+for key,value in os.environ.iteritems():
+ try:
+ value.encode()
+ except UnicodeDecodeError:
+ print key
+EOF
+}
+
+src_compile() {
+ local lisp_compiler lisp_compiler_args
+ if use clisp; then
+ lisp_compiler="clisp"
+ lisp_compiler_args="-ansi build.lisp"
+ elif use cmucl; then
+ lisp_compiler="lisp"
+ lisp_compiler_args="-noinit -nositeinit -batch -load build.lisp"
+ else
+ lisp_compiler="sbcl"
+ lisp_compiler_args="--sysinit /dev/null --userinit /dev/null --disable-debugger --load build.lisp"
+ fi
+
+ einfo "Filtering non ASCII environment variables"
+ for var in $(getutfvars); do
+ einfo " ${var}"
+ unset ${var}
+ done
+ $lisp_compiler $lisp_compiler_args || die
+}
+
+src_install() {
+ java-pkg_dolauncher ${PN} --java_args "-Xmx256M -Xrs" --main org.armedbear.lisp.Main
+ java-pkg_doso src/org/armedbear/lisp/libabcl.so
+ java-pkg_dojar abcl.jar
+ dodoc README || die
+}
diff --git a/dev-lisp/abcl/abcl-0.20.0.ebuild b/dev-lisp/abcl/abcl-0.20.0.ebuild
new file mode 100644
index 000000000000..7b6405ce75aa
--- /dev/null
+++ b/dev-lisp/abcl/abcl-0.20.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P=${PN}-src-${PV}
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM"
+HOMEPAGE="http://common-lisp.net/project/armedbear/"
+SRC_URI="http://common-lisp.net/project/armedbear/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="jad"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5
+ jad? ( dev-java/jad-bin )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ eant abcl.compile || die "Can't compile ABCL"
+ eant abcl.jar || die "Can't make ABCL jar archive"
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+ dodoc README || die "Can't install README"
+}
diff --git a/dev-lisp/abcl/metadata.xml b/dev-lisp/abcl/metadata.xml
new file mode 100644
index 000000000000..b89ccb622774
--- /dev/null
+++ b/dev-lisp/abcl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>common-lisp</herd>
+ <herd>java</herd>
+ <longdescription>
+ Armed Bear Common Lisp (ABCL) is an implementation of ANSI Common
+ Lisp that runs in a Java virtual machine.
+ </longdescription>
+ <use>
+ <flag name='clisp'>Build Armed Bear Common Lisp using GNU CLISP</flag>
+ <flag name='cmucl'>Build Armed Bear Common Lisp using CMU Common Lisp</flag>
+ <flag name='jad'>Enable support for disassembling compiled code using JAD</flag>
+ </use>
+</pkgmetadata>