summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2023-02-07 20:59:27 -0500
committerAlfredo Tupone <tupone@gentoo.org>2023-02-08 08:57:40 +0100
commitdf2226ba0a2ea74a488dcfb996204654ef21d9ee (patch)
tree12db2f1f088c7226b8cea998b25b29fa2697fcfb /dev-libs
parentdev-embedded/xa: add 2.3.14 (diff)
downloadgentoo-df2226ba0a2ea74a488dcfb996204654ef21d9ee.tar.gz
gentoo-df2226ba0a2ea74a488dcfb996204654ef21d9ee.tar.bz2
gentoo-df2226ba0a2ea74a488dcfb996204654ef21d9ee.zip
dev-libs/cpuinfo: fix building against dev-cpp/gtest-1.13.0
Closes: https://bugs.gentoo.org/893344 Closes: https://github.com/gentoo/gentoo/pull/29474 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cpuinfo/cpuinfo-2022.03.26-r1.ebuild (renamed from dev-libs/cpuinfo/cpuinfo-2022.03.26.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-libs/cpuinfo/cpuinfo-2022.03.26.ebuild b/dev-libs/cpuinfo/cpuinfo-2022.03.26-r1.ebuild
index 28a98cb4ef7f..03c742c31f6d 100644
--- a/dev-libs/cpuinfo/cpuinfo-2022.03.26.ebuild
+++ b/dev-libs/cpuinfo/cpuinfo-2022.03.26-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,14 @@ PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
)
+src_prepare() {
+ cmake_src_prepare
+
+ # >=dev-cpp/gtest-1.13.0 depends on building with at least C++14 standard
+ sed -i -e 's/CXX_STANDARD 11/CXX_STANDARD 14/' \
+ CMakeLists.txt || die "sed failed"
+}
+
src_configure() {
local mycmakeargs=(
-DCPUINFO_BUILD_BENCHMARKS=OFF