summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-06 21:41:28 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-06 21:43:01 +0900
commitdb83e4ec27b0d190d9e49d2b3d67d1493c175c8b (patch)
tree4089ab488b6dcf2e842fa90eaaa1f832ab700b56 /dev-libs
parentdev-libs/libutf8proc: fix tests (diff)
downloadgentoo-db83e4ec27b0d190d9e49d2b3d67d1493c175c8b.tar.gz
gentoo-db83e4ec27b0d190d9e49d2b3d67d1493c175c8b.tar.bz2
gentoo-db83e4ec27b0d190d9e49d2b3d67d1493c175c8b.zip
dev-libs/libutf8proc: add static-libs USE flag
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch21
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild9
2 files changed, 3 insertions, 27 deletions
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
deleted file mode 100644
index 75e9eaac6b53..000000000000
--- a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/Makefile b/Makefile
-index e3310f7..44c8977 100644
---- a/Makefile
-+++ b/Makefile
-@@ -46,7 +46,7 @@ pkgincludedir=$(includedir:$(prefix)/%=%)
-
- .PHONY: all clean data update manifest install
-
--all: libutf8proc.a libutf8proc.$(SHLIB_EXT)
-+all: libutf8proc.$(SHLIB_EXT)
-
- clean:
- rm -f utf8proc.o libutf8proc.a libutf8proc.$(SHLIB_VERS_EXT) libutf8proc.$(SHLIB_EXT)
-@@ -104,7 +104,6 @@ install: libutf8proc.a libutf8proc.$(SHLIB_EXT) libutf8proc.$(SHLIB_VERS_EXT) li
- mkdir -m 755 -p $(DESTDIR)$(includedir)
- $(INSTALL) -m 644 utf8proc.h $(DESTDIR)$(includedir)
- mkdir -m 755 -p $(DESTDIR)$(libdir)
-- $(INSTALL) -m 644 libutf8proc.a $(DESTDIR)$(libdir)
- $(INSTALL) -m 755 libutf8proc.$(SHLIB_VERS_EXT) $(DESTDIR)$(libdir)
- mkdir -m 755 -p $(DESTDIR)$(pkgconfigdir)
- $(INSTALL) -m 644 libutf8proc.pc $(DESTDIR)$(pkgconfigdir)/libutf8proc.pc
diff --git a/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild b/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild
index 7998589fb90d..9657f0d5e0c0 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild
@@ -12,18 +12,14 @@ SRC_URI="https://github.com/JuliaStrings/${PN#lib}/archive/v${PV}.tar.gz -> ${P}
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="test"
+IUSE="static-libs test"
RESTRICT="!test? ( test )"
BDEPEND="test? ( =app-i18n/unicode-data-12.0* )"
S="${WORKDIR}/${P#lib}"
-PATCHES=(
- # Don't build or install static libs
- "${FILESDIR}/${PN}-2.3.0-no-static.patch"
- "${FILESDIR}"/${PN}-grapheme-test.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-grapheme-test.patch )
src_compile() {
emake \
@@ -37,6 +33,7 @@ src_install() {
prefix="/usr" \
libdir="/usr/$(get_libdir)" \
install
+ use static-libs || find "${ED}" -name '*.a' -delete || die
# This package used to use netsurf's version as an upstream, which lives in
# its own little world. Unlike julia's version, it puts its header file
# in libutf8proc/utf8proc.h instead of utf8proc.h. The problem is that