summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-02 17:04:16 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-02 17:04:43 +0300
commitda77cabcae7381d4e56cb56918af3cc8b541f1af (patch)
treeade52defe300f238f440f4b08caf5fff4a618004 /dev-libs
parentdev-libs/libwacom: amd64 stable wrt bug #693214 (diff)
downloadgentoo-da77cabcae7381d4e56cb56918af3cc8b541f1af.tar.gz
gentoo-da77cabcae7381d4e56cb56918af3cc8b541f1af.tar.bz2
gentoo-da77cabcae7381d4e56cb56918af3cc8b541f1af.zip
dev-libs/gjs-1.56.2: get tests to pass
Disabled Xvfb tests for now, as some of them are having issues with discussions with upstream ongoing. Wrap the tests run inside dbus-run-session, despite upstream Makefiles trying to do that already for some tests - seem to be missing for some, or other mysterious problems when not doing our own dbus-run-session too. Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gjs/gjs-1.56.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/gjs/gjs-1.56.2.ebuild b/dev-libs/gjs/gjs-1.56.2.ebuild
index 071966de1530..d436481cec50 100644
--- a/dev-libs/gjs/gjs-1.56.2.ebuild
+++ b/dev-libs/gjs/gjs-1.56.2.ebuild
@@ -44,8 +44,9 @@ src_configure() {
$(use_with gtk) \
$(use_enable readline) \
$(use_with test dbus-tests) \
- $(use_with test xvfb-tests) \
- --disable-installed-tests
+ --disable-installed-tests \
+ --without-xvfb-tests
+ #$(use_with test xvfb-tests) # https://gitlab.gnome.org/GNOME/gjs/issues/280
}
src_install() {
@@ -62,5 +63,5 @@ src_install() {
}
src_test() {
- virtx default
+ virtx dbus-run-session emake check || die
}