summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-02-03 21:53:24 -0500
committerMike Gilbert <floppym@gentoo.org>2023-02-03 22:13:53 -0500
commitbf435595a9b979a91898c1d86958cb776a31b192 (patch)
treee285e8dd81be3476f831cc244434ea9698065478 /dev-libs
parentdev-libs/openssl: optimize docs build (diff)
downloadgentoo-bf435595a9b979a91898c1d86958cb776a31b192.tar.gz
gentoo-bf435595a9b979a91898c1d86958cb776a31b192.tar.bz2
gentoo-bf435595a9b979a91898c1d86958cb776a31b192.zip
dev-libs/openssl: drop Makefile CFLAGS hackery
From what I can tell, the current build system respects CFLAGS without any intervention. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/openssl-3.0.7-r4.ebuild23
1 files changed, 1 insertions, 22 deletions
diff --git a/dev-libs/openssl/openssl-3.0.7-r4.ebuild b/dev-libs/openssl/openssl-3.0.7-r4.ebuild
index 6921c7f98501..0fd8cec1764e 100644
--- a/dev-libs/openssl/openssl-3.0.7-r4.ebuild
+++ b/dev-libs/openssl/openssl-3.0.7-r4.ebuild
@@ -201,28 +201,7 @@ multilib_src_configure() {
threads
)
- CFLAGS= LDFLAGS= edo perl Configure "${myeconfargs[@]}"
-
- # Clean out hardcoded flags that openssl uses
- local DEFAULT_CFLAGS=$(grep ^CFLAGS= Makefile | LC_ALL=C sed \
- -e 's:^CFLAGS=::' \
- -e 's:\(^\| \)-fomit-frame-pointer::g' \
- -e 's:\(^\| \)-O[^ ]*::g' \
- -e 's:\(^\| \)-march=[^ ]*::g' \
- -e 's:\(^\| \)-mcpu=[^ ]*::g' \
- -e 's:\(^\| \)-m[^ ]*::g' \
- -e 's:^ *::' \
- -e 's: *$::' \
- -e 's: \+: :g' \
- -e 's:\\:\\\\:g'
- )
-
- # Now insert clean default flags with user flags
- sed -i \
- -e "/^CFLAGS=/s|=.*|=${DEFAULT_CFLAGS} ${CFLAGS}|" \
- -e "/^LDFLAGS=/s|=[[:space:]]*$|=${LDFLAGS}|" \
- Makefile \
- || die
+ edo perl Configure "${myeconfargs[@]}"
}
multilib_src_compile() {