summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-05-29 08:43:51 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-05-29 08:46:27 +0200
commit4ac912eb86373c336db387e633fe4c6de8ecd058 (patch)
tree72c8211aff2f3dfad49f5a7963dc90e7cdff5492 /dev-libs
parentdev-libs/serd: bump to 0.30.12, added python3_11 (diff)
downloadgentoo-4ac912eb86373c336db387e633fe4c6de8ecd058.tar.gz
gentoo-4ac912eb86373c336db387e633fe4c6de8ecd058.tar.bz2
gentoo-4ac912eb86373c336db387e633fe4c6de8ecd058.zip
dev-libs/sord: bump to 0.16.10, added python3_11
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/sord/Manifest1
-rw-r--r--dev-libs/sord/sord-0.16.10.ebuild59
-rw-r--r--dev-libs/sord/sord-9999.ebuild4
3 files changed, 62 insertions, 2 deletions
diff --git a/dev-libs/sord/Manifest b/dev-libs/sord/Manifest
index 3a2424291494..708a0c84e813 100644
--- a/dev-libs/sord/Manifest
+++ b/dev-libs/sord/Manifest
@@ -1 +1,2 @@
+DIST sord-0.16.10.tar.bz2 524630 BLAKE2B 6737d3495846529e6e4d14cbb2ac47ce4e67d04298381a119ba0107144deb56a53de9aa363397c2e302535f998c7c3ad44d340f52f70ac341ad6b635db608cb6 SHA512 715201eaf4a13a3635337cf8fa7c1a1f229f1d589f70cdf8f67183d90df29cd8b4af180650ce9cd0c651c712d11901bfdc6b51f9b8d7c6e70d8d8f30b1861281
DIST sord-0.16.8.tar.bz2 525038 BLAKE2B 3ba43b2edb69efec64ac68f139a18f23dc1b92290b054f420c400d2907af74fa550b042596374136c53b7cf0db1b775cfc7edd24c771bbf26d25928845787c7b SHA512 24ed50de8e5bb321e557bac6d3e441b2ed49adabf828bf0e1b33a080c89306dde80443dc8b563098fcc184c4d6e53b7e716b523ddccdf56d08301d1b0120f2b2
diff --git a/dev-libs/sord/sord-0.16.10.ebuild b/dev-libs/sord/sord-0.16.10.ebuild
new file mode 100644
index 000000000000..b534740a2a7d
--- /dev/null
+++ b/dev-libs/sord/sord-0.16.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/serd
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+"
+DOCS=( "AUTHORS" "NEWS" "README.md" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(multilib_native_usex doc --docs "") \
+ $(usex test --test "") \
+ $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+ ./waf test || die
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+ default
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ default
+}
diff --git a/dev-libs/sord/sord-9999.ebuild b/dev-libs/sord/sord-9999.ebuild
index 815103371d51..fbe89d308563 100644
--- a/dev-libs/sord/sord-9999.ebuild
+++ b/dev-libs/sord/sord-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE='threads(+)'
inherit python-any-r1 waf-utils multilib-build multilib-minimal git-r3