summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-16 10:26:38 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-16 12:20:58 +0200
commit3f713bd7a27a7fb1a971581175a31aeae81154f6 (patch)
tree0b652e8bfd1f6e38f9adcef0d411135588a33b82 /dev-libs
parentx11-plugins/enigmail: Removed old. (diff)
downloadgentoo-3f713bd7a27a7fb1a971581175a31aeae81154f6.tar.gz
gentoo-3f713bd7a27a7fb1a971581175a31aeae81154f6.tar.bz2
gentoo-3f713bd7a27a7fb1a971581175a31aeae81154f6.zip
dev-libs/poco: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/poco/metadata.xml1
-rw-r--r--dev-libs/poco/poco-1.4.6_p4-r1.ebuild121
-rw-r--r--dev-libs/poco/poco-1.9.0-r1.ebuild128
3 files changed, 0 insertions, 250 deletions
diff --git a/dev-libs/poco/metadata.xml b/dev-libs/poco/metadata.xml
index 56b0f650afc8..6c90e505339c 100644
--- a/dev-libs/poco/metadata.xml
+++ b/dev-libs/poco/metadata.xml
@@ -24,7 +24,6 @@ done quickly and working on the features that make their application unique.
</upstream>
<use>
<flag name="7z">Add Support for the 7z archive format</flag>
- <flag name="apache">Enable support to write Apache modules using POCO</flag>
<flag name="cppparser">Build and install a minimal C++ parser</flag>
<flag name="crypto">Encryption and digital signing classes</flag>
<flag name="data">Database abstraction layer to easily send/retrieve data to/from various databases</flag>
diff --git a/dev-libs/poco/poco-1.4.6_p4-r1.ebuild b/dev-libs/poco/poco-1.4.6_p4-r1.ebuild
deleted file mode 100644
index c148f9b0f5e9..000000000000
--- a/dev-libs/poco/poco-1.4.6_p4-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs flag-o-matic multilib versionator
-
-MY_P="${P/_}"
-MY_DOCP="${PN}-$(get_version_component_range 1-3)-all-doc"
-
-DESCRIPTION="C++ libraries for building network-based applications"
-HOMEPAGE="https://pocoproject.org/"
-SRC_URI="https://pocoproject.org/releases/poco-$(get_version_component_range 1-3)/${MY_P}-all.tar.bz2
- doc? ( mirror://sourceforge/poco/${MY_DOCP}.zip )"
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples iodbc libressl mysql odbc sqlite ssl test"
-
-DEPEND=">=dev-libs/libpcre-8.13
- dev-libs/expat
- sys-libs/zlib
- mysql? ( virtual/mysql )
- odbc? ( iodbc? ( dev-db/libiodbc )
- !iodbc? ( dev-db/unixODBC ) )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- )
- sqlite? ( dev-db/sqlite:3 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}-all"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/poco-1.4.4-patch-for-libpcre-8.32.patch
-}
-
-src_configure() {
- targets="libexecs"
- odbc="unixodbc"
-
- if use ssl; then
- targets="${targets} NetSSL_OpenSSL-libexec Crypto-libexec"
- echo NetSSL_OpenSSL >> components
- echo Crypto >> components
- fi
- if use odbc; then
- targets="${targets} Data/ODBC-libexec"
- echo Data/ODBC >> components
- if use iodbc; then
- append-flags "-I/usr/include/iodbc"
- odbc="iodbc"
- fi
- fi
- if use sqlite; then
- targets="${targets} Data/SQLite-libexec"
- echo Data/SQLite >> components
- fi
- if use mysql; then
- targets="${targets} Data/MySQL-libexec"
- echo Data/MySQL >> components
- fi
-
- if use test; then
- targets="${targets} cppunit tests"
- echo CppUnit >> components
- use ssl && targets="${targets} NetSSL_OpenSSL-tests Crypto-tests"
- use odbc && targets="${targets} Data/ODBC-tests"
- use sqlite && targets="${targets} Data/SQLite-tests"
- use mysql && targets="${targets} Data/MySQL-tests"
- fi
-
- local myconf
- use test || myconf="--no-tests"
- # not autoconf
- ./configure \
- --no-samples ${myconf} \
- --prefix=/usr \
- --unbundled \
- || die "configure failed"
-
- sed -i \
- -e 's|-O2||g' \
- -e "s|CC = .*|CC = $(tc-getCC)|" \
- -e "s|CXX = .*|CXX = $(tc-getCXX)|" \
- -e "s|RANLIB = .*|RANLIB = $(tc-getRANLIB)|" \
- -e "s|LIB = ar|LIB = $(tc-getAR)|" \
- -e "s|STRIP = .*|STRIP = /bin/true|" \
- -e "s|CFLAGS = |CFLAGS = ${CFLAGS}|" \
- -e "s|CXXFLAGS = |CXXFLAGS = ${CXXFLAGS} |" \
- -e "s|LINKFLAGS =|LINKFLAGS = ${LDFLAGS} |" \
- -e "s|SHAREDOPT_LINK = -Wl,-rpath,\$(LIBPATH)|SHAREDOPT_LINK =|" \
- build/config/Linux build/config/FreeBSD || die "sed failed"
- sed -i -e "s|SHLIBFLAGS)|SHLIBFLAGS) ${LDFLAGS}|" build/rules/lib || die
-}
-
-src_compile() {
- emake POCO_PREFIX=/usr GENTOO_ODBC="${odbc}" LIBDIR="$(get_libdir)" ${targets} || die "emake failed"
-}
-
-src_install() {
- emake POCO_PREFIX=/usr LIBDIR="$(get_libdir)" DESTDIR="${D}" install || die "emake install failed"
-
- dodoc CHANGELOG CONTRIBUTORS NEWS README
-
- use doc && dohtml -r "${WORKDIR}/${MY_DOCP}"/*
-
- if use examples ; then
- for d in Net XML Data Util NetSSL_OpenSSL Foundation ; do
- insinto /usr/share/doc/${PF}/examples/${d}
- doins -r ${d}/samples
- done
- find "${D}/usr/share/doc/${PF}/examples" \
- -iname "*.sln" -or -iname "*.vcproj" -or \
- -iname "*.vmsbuild" -or -iname "*.properties" \
- | xargs rm
- fi
-}
diff --git a/dev-libs/poco/poco-1.9.0-r1.ebuild b/dev-libs/poco/poco-1.9.0-r1.ebuild
deleted file mode 100644
index a00decb0b061..000000000000
--- a/dev-libs/poco/poco-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="C++ libraries for building network-based applications"
-HOMEPAGE="https://pocoproject.org/"
-SRC_URI="https://github.com/pocoproject/${PN}/archive/${P}-release.tar.gz -> ${P}.tar.gz"
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="7z apache cppparser +crypto +data examples +file2pagecompiler +json +pagecompiler iodbc libressl mariadb +mongodb mysql +net odbc pdf pocodoc sqlite +ssl test +util +xml +zip"
-REQUIRED_USE="7z? ( xml )
- apache? ( net util )
- file2pagecompiler? ( pagecompiler )
- iodbc? ( odbc )
- mongodb? ( data )
- mysql? ( data )
- odbc? ( data )
- pagecompiler? ( json net util xml )
- pocodoc? ( cppparser util xml )
- sqlite? ( data )
- test? ( data? ( sqlite ) json util xml )"
-
-RDEPEND=">=dev-libs/libpcre-8.13
- xml? ( dev-libs/expat )
- apache? ( dev-libs/apr
- dev-libs/apr-util
- www-servers/apache )
- mysql? ( !mariadb? ( dev-db/mysql-connector-c:0= )
- mariadb? ( dev-db/mariadb-connector-c:0= ) )
- odbc? ( iodbc? ( dev-db/libiodbc )
- !iodbc? ( dev-db/unixODBC ) )
- ssl? (
- !libressl? ( <dev-libs/openssl-1.1.0:0= )
- libressl? ( dev-libs/libressl )
- )
- sqlite? ( dev-db/sqlite:3 )
- zip? ( sys-libs/zlib )"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}-${P}-release"
-
-PATCHES=( "${FILESDIR}/${PN}-1.7.2-iodbc-incdir.patch" )
-
-src_prepare() {
- if use test ; then
- # ignore missing tests on experimental library
- # and tests requiring running DB-servers, internet connections, etc.
- sed -i \
- -e '/testsuite/d' \
- {Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF}/CMakeLists.txt || die
- # Poco expands ~ using passwd, which does not match $HOME in the build environment
- sed -i \
- -e '/CppUnit_addTest.*testExpand/d' \
- Foundation/testsuite/src/PathTest.cpp || die
- # ignore failing Crypto test since upstream does not seem to care,
- # see https://github.com/pocoproject/poco/issues/1209
- sed -i \
- -e '/RSATest, testRSACipherLarge/d' \
- Crypto/testsuite/src/RSATest.cpp || die
- fi
-
- if use mariadb ; then
- # Fix MariaDB detection
- sed -i -e 's~/usr/include/mysql~~' \
- -e 's/STATUS "Couldn/FATAL_ERROR "Couldn/' \
- cmake/FindMySQL.cmake || die
- else
- # Fix MySQL detection
- sed -i -e 's/mysqlclient_r/mysqlclient/' \
- -e 's/STATUS "Couldn/FATAL_ERROR "Couldn/' \
- cmake/FindMySQL.cmake || die
- fi
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DPOCO_UNBUNDLED=ON
- -DENABLE_APACHECONNECTOR="$(usex apache)"
- -DENABLE_CPPPARSER="$(usex cppparser)"
- -DENABLE_CRYPTO="$(usex ssl)"
- -DENABLE_DATA="$(usex data)"
- -DENABLE_DATA_MYSQL="$(usex mysql)"
- -DENABLE_DATA_ODBC="$(usex odbc)"
- -DENABLE_DATA_SQLITE="$(usex sqlite)"
- -DENABLE_JSON="$(usex util)"
- -DENABLE_MONGODB="$(usex mongodb)"
- -DENABLE_NET="$(usex net)"
- -DENABLE_NETSSL="$(usex ssl)"
- -DENABLE_NETSSL_WIN=OFF
- -DENABLE_PAGECOMPILER="$(usex pagecompiler)"
- -DENABLE_PAGECOMPILER_FILE2PAGE="$(usex file2pagecompiler)"
- -DENABLE_PDF="$(usex pdf)"
- -DENABLE_POCODOC="$(usex pocodoc)"
- -DENABLE_SEVENZIP="$(usex 7z)"
- -DENABLE_TESTS="$(usex test)"
- -DENABLE_UTIL="$(usex util)"
- -DENABLE_XML="$(usex xml)"
- -DENABLE_ZIP="$(usex zip)"
- )
-
- if ! use iodbc ; then
- sed -i -e 's|iodbc||' cmake/FindODBC.cmake || die
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use examples ; then
- for sd in */samples ; do
- insinto /usr/share/doc/${PF}/examples/${sd%/samples}
- doins -r ${sd}
- done
- find "${D}/usr/share/doc/${PF}/examples" \
- -iname "*.sln" -or -iname "*.vcproj" -or \
- -iname "*.vmsbuild" -or -iname "*.properties" \
- | xargs rm
- fi
-}