summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Smirnov <civil@gentoo.org>2018-06-15 21:54:55 +0200
committerVladimir Smirnov <civil@gentoo.org>2018-06-15 21:54:55 +0200
commit369ceeaf4161191121b6f382ed3a16435a8698a5 (patch)
tree1798c77b92a2bc0fa7eee9518eb4b5e0c6596450 /dev-libs
parentdev-python/mkdocs: Bump to 0.17.4 (diff)
downloadgentoo-369ceeaf4161191121b6f382ed3a16435a8698a5.tar.gz
gentoo-369ceeaf4161191121b6f382ed3a16435a8698a5.tar.bz2
gentoo-369ceeaf4161191121b6f382ed3a16435a8698a5.zip
dev-libs/poco: Bump to 1.9.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/poco/Manifest1
-rw-r--r--dev-libs/poco/poco-1.9.0.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/dev-libs/poco/Manifest b/dev-libs/poco/Manifest
index a7555b63be05..11f74b01b3c6 100644
--- a/dev-libs/poco/Manifest
+++ b/dev-libs/poco/Manifest
@@ -1,3 +1,4 @@
DIST poco-1.4.6-all-doc.zip 2072762 BLAKE2B 51b8426d050e7ae373fbb0f3959657e37f1c3aeda75f5bf5cd3dc99e08414a9e65f61ea71dee6d8c40148f41157e2eac0888e64c5020707352c74b262ffae741 SHA512 458e1a3c6a6017b5ae5efcbd0d7b2bbf50aedd6ddc7ae7befddac07ed133b7243208aadd6ecdb17b3fa273e04eb0da4d73b1d3e5591aee98b754e430b2248e52
DIST poco-1.4.6p4-all.tar.bz2 3158594 BLAKE2B 76accf617ddd087131a5960c131680451959704fee4b17b65bf85367a172d2fe023c9c7efde59fe5bd4142c7ca153734fb4ccbbf06bd5d0365a59d6e75a328a5 SHA512 ae4e1190a0ba719f807d0abaf1c47ff445a8f5867157f209260672546f3755ff021c7073bc8d5e656be383d5667dc15ad7eae8208728053fb61439c4c80a7fca
DIST poco-1.7.6.tar.gz 8044937 BLAKE2B ad9bf61eb00ce4e1ef5079e07be04ceff79bf823cba49ffb0e144a1e579d9de4f6f8d3df6b629c522de5c2b7b4c7df0933777686b72190d717e407bc28ae2a49 SHA512 a02b7ff66acf080942517b3b8644d6e5c7136c5edc6e58fd13083a74b97b5619253fc9db7863284a565226f95410ad4da1fa9738d14885f560aeb03c1f7c18aa
+DIST poco-1.9.0.tar.gz 10012966 BLAKE2B 98848e87008c71dc5131dbd1c2b17afc414074a3e26237918baf231b4e56ce3d69347cf7a3017715895f4ee56a428672fcb804fb3c732da0000ccc9790b0081d SHA512 de2346d62b2e89ba04abe62a83f6ede7a496e80bcbe53a880a1aa8e87a8ebd9a430dd70fdc6aada836bb1021c6df21375fd0cbcf62dbb6e29a2f65d6d90cf2b9
diff --git a/dev-libs/poco/poco-1.9.0.ebuild b/dev-libs/poco/poco-1.9.0.ebuild
new file mode 100644
index 000000000000..b6b741001baa
--- /dev/null
+++ b/dev-libs/poco/poco-1.9.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++ libraries for building network-based applications"
+HOMEPAGE="http://pocoproject.org/"
+SRC_URI="https://github.com/pocoproject/${PN}/archive/${P}-release.tar.gz -> ${P}.tar.gz"
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="7z apache cppparser +crypto +data examples +file2pagecompiler +json +pagecompiler iodbc libressl +mongodb mysql +net odbc pdf pocodoc sqlite +ssl test +util +xml +zip"
+REQUIRED_USE="7z? ( xml )
+ apache? ( net util )
+ file2pagecompiler? ( pagecompiler )
+ iodbc? ( odbc )
+ mongodb? ( data )
+ mysql? ( data )
+ odbc? ( data )
+ pagecompiler? ( json net util xml )
+ pocodoc? ( cppparser util xml )
+ sqlite? ( data )
+ test? ( data? ( sqlite ) json util xml )"
+
+RDEPEND=">=dev-libs/libpcre-8.13
+ xml? ( dev-libs/expat )
+ apache? ( dev-libs/apr
+ dev-libs/apr-util
+ www-servers/apache )
+ mysql? ( virtual/mysql )
+ odbc? ( iodbc? ( dev-db/libiodbc )
+ !iodbc? ( dev-db/unixODBC ) )
+ ssl? (
+ !libressl? ( <dev-libs/openssl-1.1.0:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ zip? ( sys-libs/zlib )"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}-release"
+
+PATCHES=( "${FILESDIR}/${PN}-1.7.2-iodbc-incdir.patch" )
+
+src_prepare() {
+ if use test ; then
+ # ignore missing tests on experimental library
+ # and tests requiring running DB-servers, internet connections, etc.
+ sed -i \
+ -e '/testsuite/d' \
+ {Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF}/CMakeLists.txt || die
+ # Poco expands ~ using passwd, which does not match $HOME in the build environment
+ sed -i \
+ -e '/CppUnit_addTest.*testExpand/d' \
+ Foundation/testsuite/src/PathTest.cpp || die
+ # ignore failing Crypto test since upstream does not seem to care,
+ # see https://github.com/pocoproject/poco/issues/1209
+ sed -i \
+ -e '/RSATest, testRSACipherLarge/d' \
+ Crypto/testsuite/src/RSATest.cpp || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPOCO_UNBUNDLED=ON
+ -DENABLE_APACHECONNECTOR="$(usex apache)"
+ -DENABLE_CPPPARSER="$(usex cppparser)"
+ -DENABLE_CRYPTO="$(usex ssl)"
+ -DENABLE_DATA="$(usex data)"
+ -DENABLE_DATA_MYSQL="$(usex mysql)"
+ -DENABLE_DATA_ODBC="$(usex odbc)"
+ -DENABLE_DATA_SQLITE="$(usex sqlite)"
+ -DENABLE_JSON="$(usex util)"
+ -DENABLE_MONGODB="$(usex mongodb)"
+ -DENABLE_NET="$(usex net)"
+ -DENABLE_NETSSL="$(usex ssl)"
+ -DENABLE_NETSSL_WIN=OFF
+ -DENABLE_PAGECOMPILER="$(usex pagecompiler)"
+ -DENABLE_PAGECOMPILER_FILE2PAGE="$(usex file2pagecompiler)"
+ -DENABLE_PDF="$(usex pdf)"
+ -DENABLE_POCODOC="$(usex pocodoc)"
+ -DENABLE_SEVENZIP="$(usex 7z)"
+ -DENABLE_TESTS="$(usex test)"
+ -DENABLE_UTIL="$(usex util)"
+ -DENABLE_XML="$(usex xml)"
+ -DENABLE_ZIP="$(usex zip)"
+ )
+
+ if ! use iodbc ; then
+ sed -i -e 's|iodbc||' cmake/FindODBC.cmake || die
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples ; then
+ for sd in */samples ; do
+ insinto /usr/share/doc/${PF}/examples/${sd%/samples}
+ doins -r ${sd}
+ done
+ find "${D}/usr/share/doc/${PF}/examples" \
+ -iname "*.sln" -or -iname "*.vcproj" -or \
+ -iname "*.vmsbuild" -or -iname "*.properties" \
+ | xargs rm
+ fi
+}