summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-12 22:51:23 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-12 22:51:23 +0200
commit23c4307a73d0d7fa1d79c0a95125918cf8a38bc6 (patch)
tree430fb21e16ff0b0716aa9392e12394d61c4564b1 /dev-libs
parentmedia-libs/mesa: bump x11-libs/libva dep. (diff)
downloadgentoo-23c4307a73d0d7fa1d79c0a95125918cf8a38bc6.tar.gz
gentoo-23c4307a73d0d7fa1d79c0a95125918cf8a38bc6.tar.bz2
gentoo-23c4307a73d0d7fa1d79c0a95125918cf8a38bc6.zip
dev-libs/libclc: Revert "fix llvm-config path."
Revert the non-maintainer commit that reintroduced the cross-slot clang mismatch bug.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild b/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
index 003757a0998e..c0ac06980cb4 100644
--- a/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
+++ b/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
@@ -39,9 +39,13 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}"
src_configure() {
+ # we need to find llvm with matching clang version, so look for
+ # clang first, and then use llvm-config from the same location
+ local clang_path=$(type -P clang) || die
+
./configure.py \
--with-cxx-compiler="$(tc-getCXX)" \
- --with-llvm-config="$(tc-getPROG LLVM_CONFIG llvm-config)" \
+ --with-llvm-config="${clang_path%/*}/llvm-config" \
--prefix="${EPREFIX}/usr" || die
}