summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-10-08 15:07:25 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-10-08 17:35:26 +0300
commit211b4ad2a2699dac8dd8765323e23dfc7fab286e (patch)
tree82a689e1cbf835976fe16b68747d0f7231a7103f /dev-libs
parentdev-libs/hyperscan: Fix build for gcc9.x (diff)
downloadgentoo-211b4ad2a2699dac8dd8765323e23dfc7fab286e.tar.gz
gentoo-211b4ad2a2699dac8dd8765323e23dfc7fab286e.tar.bz2
gentoo-211b4ad2a2699dac8dd8765323e23dfc7fab286e.zip
dev-libs/hyperscan: Fix EAPI + BDEPS
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/hyperscan/hyperscan-5.1.0.ebuild2
-rw-r--r--dev-libs/hyperscan/hyperscan-5.1.1.ebuild4
-rw-r--r--dev-libs/hyperscan/hyperscan-5.2.0.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/hyperscan/hyperscan-5.1.0.ebuild b/dev-libs/hyperscan/hyperscan-5.1.0.ebuild
index b73f317040a3..8cecb0a904af 100644
--- a/dev-libs/hyperscan/hyperscan-5.1.0.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.1.0.ebuild
@@ -23,7 +23,7 @@ RDEPEND="
>=dev-libs/boost-1.57:=
net-libs/libpcap"
-DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
REQUIRED_USE="cpu_flags_x86_ssse3
${PYTHON_REQUIRED_USE}"
diff --git a/dev-libs/hyperscan/hyperscan-5.1.1.ebuild b/dev-libs/hyperscan/hyperscan-5.1.1.ebuild
index 7a0a28063f9f..6e6970b8c429 100644
--- a/dev-libs/hyperscan/hyperscan-5.1.1.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
@@ -20,7 +20,7 @@ RDEPEND="${PYTHON_DEPS}
dev-util/ragel
dev-libs/boost
net-libs/libpcap"
-DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
REQUIRED_USE="cpu_flags_x86_ssse3 ${PYTHON_REQUIRED_USE}"
diff --git a/dev-libs/hyperscan/hyperscan-5.2.0.ebuild b/dev-libs/hyperscan/hyperscan-5.2.0.ebuild
index 7a0a28063f9f..6e6970b8c429 100644
--- a/dev-libs/hyperscan/hyperscan-5.2.0.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
@@ -20,7 +20,7 @@ RDEPEND="${PYTHON_DEPS}
dev-util/ragel
dev-libs/boost
net-libs/libpcap"
-DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
REQUIRED_USE="cpu_flags_x86_ssse3 ${PYTHON_REQUIRED_USE}"