summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-08-07 13:53:43 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-08-07 13:53:43 +0100
commit286a7c3cf202ae0f130d0996a84ee224f1c3dfc3 (patch)
tree993bb1d9691254ab056ae9c80a15fea8f0ede339 /dev-libs/weston
parentRevert "python-utils-r1.eclass: Remove old EAPI hack for exporting PYTHON" (diff)
downloadgentoo-286a7c3cf202ae0f130d0996a84ee224f1c3dfc3.tar.gz
gentoo-286a7c3cf202ae0f130d0996a84ee224f1c3dfc3.tar.bz2
gentoo-286a7c3cf202ae0f130d0996a84ee224f1c3dfc3.zip
dev-libs/weston: Fix building with Python 3.12
setuptools is required with 3.12 due to a current issue in Meson. Unfortunately, we cannot easily express this only for 3.12, but it's not a big deal in practise. Closes: https://bugs.gentoo.org/911748 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-libs/weston')
-rw-r--r--dev-libs/weston/weston-12.0.2.ebuild1
-rw-r--r--dev-libs/weston/weston-9999.ebuild5
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-libs/weston/weston-12.0.2.ebuild b/dev-libs/weston/weston-12.0.2.ebuild
index 8fa6eb73fb76..b7c0da5886be 100644
--- a/dev-libs/weston/weston-12.0.2.ebuild
+++ b/dev-libs/weston/weston-12.0.2.ebuild
@@ -90,6 +90,7 @@ BDEPEND="
${PYTHON_DEPS}
dev-util/wayland-scanner
virtual/pkgconfig
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
"
src_configure() {
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 3c346567c682..b7c0da5886be 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
EXPERIMENTAL="true"
fi
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit meson python-any-r1 readme.gentoo-r1 xdg-utils ${GIT_ECLASS}
DESCRIPTION="Wayland reference compositor"
@@ -19,7 +19,7 @@ if [[ ${PV} = *9999* ]]; then
SRC_URI="${SRC_PATCHES}"
else
SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~riscv ~x86"
fi
LICENSE="MIT CC-BY-SA-3.0"
@@ -90,6 +90,7 @@ BDEPEND="
${PYTHON_DEPS}
dev-util/wayland-scanner
virtual/pkgconfig
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
"
src_configure() {