summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2020-09-07 14:15:12 +0200
committerCédric Krier <cedk@gentoo.org>2020-09-07 14:17:03 +0200
commite140dbe032d48ad70ec979af0a2e02f6df905006 (patch)
treea60ace58a85f102778e1e7d1bc9264e3e0583e3f /dev-libs/stfl
parentapp-backup/burp: bump to 2.3.34 (diff)
downloadgentoo-e140dbe032d48ad70ec979af0a2e02f6df905006.tar.gz
gentoo-e140dbe032d48ad70ec979af0a2e02f6df905006.tar.bz2
gentoo-e140dbe032d48ad70ec979af0a2e02f6df905006.zip
dev-libs/stfl: Remove hardcoded pkg-config libdir
Closes: https://bugs.gentoo.org/740854 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-libs/stfl')
-rw-r--r--dev-libs/stfl/files/stfl-0.22-pc-libdir.patch24
-rw-r--r--dev-libs/stfl/stfl-0.24-r3.ebuild125
2 files changed, 149 insertions, 0 deletions
diff --git a/dev-libs/stfl/files/stfl-0.22-pc-libdir.patch b/dev-libs/stfl/files/stfl-0.22-pc-libdir.patch
new file mode 100644
index 000000000000..82a9529c9573
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.22-pc-libdir.patch
@@ -0,0 +1,24 @@
+diff -ru stfl-0.24.orig/Makefile stfl-0.24/Makefile
+--- stfl-0.24.orig/Makefile 2015-02-12 14:14:33.000000000 +0100
++++ stfl-0.24/Makefile 2020-09-07 14:08:04.125833347 +0200
+@@ -67,7 +67,7 @@
+ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libstfl.so
+
+ stfl.pc: stfl.pc.in
+- sed 's,@VERSION@,$(VERSION),g' < $< | sed 's,@PREFIX@,$(prefix),g' > $@
++ sed 's,@VERSION@,$(VERSION),g' < $< | sed 's,@PREFIX@,$(prefix),g' | sed 's,@LIBDIR@,${libdir},g' > $@
+
+ ifeq ($(FOUND_SPL),1)
+ include spl/Makefile.snippet
+diff -ru stfl-0.24.orig/stfl.pc.in stfl-0.24/stfl.pc.in
+--- stfl-0.24.orig/stfl.pc.in 2009-03-30 20:33:37.000000000 +0200
++++ stfl-0.24/stfl.pc.in 2020-09-07 14:08:07.784854088 +0200
+@@ -2,7 +2,7 @@
+
+ prefix=@PREFIX@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
++libdir=${exec_prefix}/@LIBDIR@
+ includedir=${prefix}/include
+
+ Name: STFL
diff --git a/dev-libs/stfl/stfl-0.24-r3.ebuild b/dev-libs/stfl/stfl-0.24-r3.ebuild
new file mode 100644
index 000000000000..f05ef3b01cb9
--- /dev/null
+++ b/dev-libs/stfl/stfl-0.24-r3.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..8} )
+GENTOO_DEPEND_ON_PERL=no
+inherit eutils multilib perl-module python-r1 toolchain-funcs
+
+DESCRIPTION="A library which implements a curses-based widget set for text terminals"
+HOMEPAGE="http://www.clifford.at/stfl/"
+SRC_URI="http://www.clifford.at/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples perl python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby:* )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ perl? ( dev-lang/swig )
+ python? ( >=dev-lang/swig-1.3.40 )
+ ruby? ( dev-lang/swig )
+"
+RESTRICT="test" # Upstream does not provide tests #730112
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.21-python.patch"
+ "${FILESDIR}/${PN}-0.22-soname-symlink.patch"
+ "${FILESDIR}/${PN}-0.22-ruby-sharedlib.patch"
+ "${FILESDIR}/${PN}-0.22-pc-libdir.patch"
+)
+
+src_prepare() {
+ default_src_prepare
+ sed -i \
+ -e 's/-Os -ggdb//' \
+ -e 's/^\(all:.*\) example/\1/' \
+ -e 's/$(CC) -shared/$(CC) $(LDFLAGS) -shared/' \
+ -e 's/ -o $@ $(LDLIBS) $^/ $^ $(LDLIBS) -o $@/' \
+ -e 's/-lncursesw/-lncursesw -pthread/' \
+ -e 's/\<ar\>/$(AR)/' \
+ -e 's/\<ranlib\>/$(RANLIB)/' \
+ Makefile || die "sed failed"
+
+ if ! use static-libs ; then
+ sed -i -e "/install .* libstfl.a/d" Makefile || die
+ fi
+
+ if use perl ; then
+ echo "FOUND_PERL5=1" >> Makefile.cfg
+ else
+ echo "FOUND_PERL5=0" >> Makefile.cfg
+ fi
+
+ if use ruby ; then
+ echo "FOUND_RUBY=1" >> Makefile.cfg
+ else
+ echo "FOUND_RUBY=0" >> Makefile.cfg
+ fi
+
+ echo "FOUND_PYTHON=0" >> Makefile.cfg
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+
+ if use python ; then
+ local BUILD_DIR="${S}/python"
+ python_copy_sources
+
+ # Based on code from python/Makefile.snippet.
+ building() {
+ pushd "${BUILD_DIR}" &>/dev/null || die
+ echo swig -python -threads stfl.i
+ swig -python -threads stfl.i || die
+ echo "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -shared -pthread -fPIC stfl_wrap.c -I$(python_get_includedir) -I.. ../libstfl.so.${PV} -lncursesw -o _stfl.so
+ "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -shared -pthread -fPIC stfl_wrap.c -I$(python_get_includedir) -I.. ../libstfl.so.${PV} -lncursesw -o _stfl.so || die
+ popd &>/dev/null || die
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_install() {
+ emake prefix="/usr" DESTDIR="${D}" libdir="$(get_libdir)" install
+
+ if use python ; then
+ local BUILD_DIR="${S}/python"
+
+ installation() {
+ pushd "${BUILD_DIR}" &>/dev/null || die
+ python_domodule stfl.py _stfl.so
+ popd &>/dev/null || die
+ }
+ python_foreach_impl installation
+ fi
+
+ dodoc README
+
+ local exdir="/usr/share/doc/${PF}/examples"
+ if use examples ; then
+ insinto ${exdir}
+ doins example.{c,stfl}
+ insinto ${exdir}/python
+ doins python/example.py
+ if use perl ; then
+ insinto ${exdir}/perl
+ doins perl5/example.pl
+ fi
+ if use ruby ; then
+ insinto ${exdir}/ruby
+ doins ruby/example.rb
+ fi
+ fi
+
+ perl_delete_localpod
+}