summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-10 18:58:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-13 02:29:09 +0200
commit98532a89b0351b032404c1f8658ed83d73641428 (patch)
treee3fa72293eef9fa5128065d0b5783ed09139ad49 /dev-libs/quazip
parentapp-accessibility/speech-dispatcher: Drop 0.8.7-r2 (diff)
downloadgentoo-98532a89b0351b032404c1f8658ed83d73641428.tar.gz
gentoo-98532a89b0351b032404c1f8658ed83d73641428.tar.bz2
gentoo-98532a89b0351b032404c1f8658ed83d73641428.zip
dev-libs/quazip: 0.9.1 version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/quazip')
-rw-r--r--dev-libs/quazip/Manifest1
-rw-r--r--dev-libs/quazip/files/quazip-0.9.1-no-static-lib.patch40
-rw-r--r--dev-libs/quazip/files/quazip-0.9.1-pkgconfig.patch31
-rw-r--r--dev-libs/quazip/quazip-0.9.1.ebuild43
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-libs/quazip/Manifest b/dev-libs/quazip/Manifest
index b6da0d2bc9a9..107af5e1dde0 100644
--- a/dev-libs/quazip/Manifest
+++ b/dev-libs/quazip/Manifest
@@ -1 +1,2 @@
DIST quazip-0.8.1.tar.gz 150584 BLAKE2B 4a1d61b65b01eee06e1292ee88b543675c77ac922d0fb1726ac0afd447d74e8c8154db82da0ce95c2f2c303c036f2795e8938a412dc22e921ee09a0ef99278f6 SHA512 d65dab16c2cbc4d8bb23dae5b2fdff5ef787aaff2653b8e75c3fc8ba1701f5568a52bdde39009f83c5069a9fe3331cd1a49cf965822c4180e88bbc341faa2bfb
+DIST quazip-0.9.1.tar.gz 155775 BLAKE2B 76710f94d055e86e1885f74b85f3e6b25f053eedbb73b4b11163e243d003ea3bad50cf1568fd2dbd37bc5db05fd0a6f8d49f48bd5df22d30b1aad3747e8ab780 SHA512 db31f3c7e3d7e95c25090ceb8379643e0b49ed69ece009dd015bee120b2b60f42e73408f580caed3138fa19ca64dcd23a05f16435abb54e2b8df21105c7b42c0
diff --git a/dev-libs/quazip/files/quazip-0.9.1-no-static-lib.patch b/dev-libs/quazip/files/quazip-0.9.1-no-static-lib.patch
new file mode 100644
index 000000000000..f0ce3e6e392f
--- /dev/null
+++ b/dev-libs/quazip/files/quazip-0.9.1-no-static-lib.patch
@@ -0,0 +1,40 @@
+From c061634452fe259dc5eb62395fbdb9159d4c9e09 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 9 Jul 2020 22:54:59 +0200
+Subject: [PATCH] Disable static lib
+
+---
+ quazip/CMakeLists.txt | 13 ++-----------
+ 1 file changed, 2 insertions(+), 11 deletions(-)
+
+diff --git a/quazip/CMakeLists.txt b/quazip/CMakeLists.txt
+index 1efb5e2..84607f6 100644
+--- a/quazip/CMakeLists.txt
++++ b/quazip/CMakeLists.txt
+@@ -11,21 +11,12 @@ qt_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
+ set(SRCS ${SRCS} ${MOC_SRCS})
+
+ add_library(${QUAZIP_LIB_TARGET_NAME} SHARED ${SRCS})
+-add_library(quazip_static STATIC ${SRCS})
+-
+-# Windows uses .lib extension for both static and shared library
+-# *nix systems use different extensions for SHARED and STATIC library and by convention both libraries have the same name
+-if (NOT WIN32)
+- set_target_properties(quazip_static PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
+-endif ()
+
+ target_include_directories(${QUAZIP_LIB_TARGET_NAME} PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${ZLIB_INCLUDE_DIRS})
+-target_include_directories(quazip_static PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${ZLIB_INCLUDE_DIRS})
+-set_target_properties(${QUAZIP_LIB_TARGET_NAME} quazip_static PROPERTIES VERSION ${QUAZIP_LIB_VERSION} SOVERSION ${QUAZIP_LIB_SOVERSION} DEBUG_POSTFIX d)
++set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES VERSION ${QUAZIP_LIB_VERSION} SOVERSION ${QUAZIP_LIB_SOVERSION} DEBUG_POSTFIX d)
+
+ # Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
+ target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+-target_link_libraries(quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+
+ install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
+-install(TARGETS ${QUAZIP_LIB_TARGET_NAME} quazip_static LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
++install(TARGETS ${QUAZIP_LIB_TARGET_NAME} LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
+--
+2.27.0
+
diff --git a/dev-libs/quazip/files/quazip-0.9.1-pkgconfig.patch b/dev-libs/quazip/files/quazip-0.9.1-pkgconfig.patch
new file mode 100644
index 000000000000..66de677611d9
--- /dev/null
+++ b/dev-libs/quazip/files/quazip-0.9.1-pkgconfig.patch
@@ -0,0 +1,31 @@
+From 94b18d81752490b694d262a4889085e9d55bc5d5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 9 Jul 2020 23:08:22 +0200
+Subject: [PATCH] Fix pkgconfig include dir
+
+---
+ quazip.pc.cmakein | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/quazip.pc.cmakein b/quazip.pc.cmakein
+index e46d4c6..4cd8c86 100644
+--- a/quazip.pc.cmakein
++++ b/quazip.pc.cmakein
+@@ -1,12 +1,12 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+ libdir=${prefix}/lib@LIB_SUFFIX@
+-includedir=${prefix}/include
++includedir=${prefix}/include/quazip@QUAZIP_LIB_VERSION_SUFFIX@
+
+
+ Name: Quazip
+ Description: Quazip Library
+ Version: @QUAZIP_LIB_VERSION@
+ Libs: -lquazip@QUAZIP_LIB_VERSION_SUFFIX@
+-Cflags:
++Cflags: -I${includedir}
+ Requires: Qt5Core
+--
+2.27.0
+
diff --git a/dev-libs/quazip/quazip-0.9.1.ebuild b/dev-libs/quazip/quazip-0.9.1.ebuild
new file mode 100644
index 000000000000..c7116322243d
--- /dev/null
+++ b/dev-libs/quazip/quazip-0.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic qmake-utils
+
+DESCRIPTION="Simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
+HOMEPAGE="https://stachenov.github.io/quazip/"
+SRC_URI="https://github.com/stachenov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-static-lib.patch"
+ "${FILESDIR}/${P}-pkgconfig.patch"
+)
+
+src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_SUFFIX=${libdir/lib/}
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # compatibility with not yet fixed rdeps (Gentoo bug #598136)
+ dosym libquazip5.so /usr/$(get_libdir)/libquazip.so
+}