summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-15 01:37:28 +0000
committerSam James <sam@gentoo.org>2021-06-15 01:37:28 +0000
commit8dc16924bbb14d50d910cebd45987735177fb152 (patch)
treeb60b19866c1c41ca15bd3a9db85bc7d23f4b05f1 /dev-libs/pegtl
parentapp-admin/tripwire: update EAPI 6 -> 7, workaround GCC 11 failure (diff)
downloadgentoo-8dc16924bbb14d50d910cebd45987735177fb152.tar.gz
gentoo-8dc16924bbb14d50d910cebd45987735177fb152.tar.bz2
gentoo-8dc16924bbb14d50d910cebd45987735177fb152.zip
dev-libs/pegtl: drop -Werror
Closes: https://bugs.gentoo.org/787854 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pegtl')
-rw-r--r--dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch56
-rw-r--r--dev-libs/pegtl/pegtl-3.2.0.ebuild5
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch b/dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch
new file mode 100644
index 000000000000..32bc4b5103ef
--- /dev/null
+++ b/dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch
@@ -0,0 +1,56 @@
+https://bugs.gentoo.org/787854
+
+From b807854fc6573d59350551578375075fc61a21e1 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 15 Jun 2021 01:31:40 +0000
+Subject: [PATCH] Drop -Werror
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ Makefile | 2 +-
+ src/example/pegtl/CMakeLists.txt | 2 +-
+ src/test/pegtl/CMakeLists.txt | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 3ecca07..2b8fa20 100644
+--- a/Makefile
++++ b/Makefile
+@@ -30,7 +30,7 @@ endif
+ # changed if desired.
+
+ CPPFLAGS ?= -pedantic
+-CXXFLAGS ?= -Wall -Wextra -Wshadow -Werror -O3 $(MINGW_CXXFLAGS)
++CXXFLAGS ?= -Wall -Wextra -Wshadow $(MINGW_CXXFLAGS)
+
+ HEADERS := $(shell find include -name '*.hpp')
+ SOURCES := $(shell find src -name '*.cpp')
+diff --git a/src/example/pegtl/CMakeLists.txt b/src/example/pegtl/CMakeLists.txt
+index d416731..4d1a417 100644
+--- a/src/example/pegtl/CMakeLists.txt
++++ b/src/example/pegtl/CMakeLists.txt
+@@ -60,7 +60,7 @@ foreach(examplesourcefile ${example_sources})
+ if(MSVC)
+ target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
+ else()
+- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
++ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow)
+ endif()
+ endforeach()
+
+diff --git a/src/test/pegtl/CMakeLists.txt b/src/test/pegtl/CMakeLists.txt
+index 577e310..84a8ab8 100644
+--- a/src/test/pegtl/CMakeLists.txt
++++ b/src/test/pegtl/CMakeLists.txt
+@@ -146,7 +146,7 @@ foreach(testsourcefile ${test_sources})
+ if(MSVC)
+ target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
+ else()
+- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
++ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow)
+ endif()
+ if(ANDROID)
+ add_test(NAME ${exename} WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} "-DANDROID_NDK=${ANDROID_NDK}" "-DTEST_RESOURCES_DIR=${CMAKE_SOURCE_DIR}" "-DTEST_RESOURCES=src/test/pegtl/data;src/test/pegtl/file_data.txt;Makefile" "-DUNITTEST=${exename}" -P ${CMAKE_CURRENT_SOURCE_DIR}/ExecuteOnAndroid.cmake)
+--
+2.32.0
+
diff --git a/dev-libs/pegtl/pegtl-3.2.0.ebuild b/dev-libs/pegtl/pegtl-3.2.0.ebuild
index 88365e453f48..638a33f9abd7 100644
--- a/dev-libs/pegtl/pegtl-3.2.0.ebuild
+++ b/dev-libs/pegtl/pegtl-3.2.0.ebuild
@@ -8,6 +8,7 @@ inherit cmake
DESCRIPTION="Header-only library for creating parsers according to Parsing Expression Grammar"
HOMEPAGE="https://github.com/taocpp/PEGTL"
SRC_URI="https://github.com/taocpp/PEGTL/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^^}"
LICENSE="MIT"
SLOT="0"
@@ -15,7 +16,9 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-S="${WORKDIR}/${P^^}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.0-no-werror.patch
+)
src_configure() {
local mycmakeargs=(