summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-21 22:51:51 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-25 07:48:30 +0300
commita93da3634c0dd6e76ce9d7c349549f8c154a2393 (patch)
treec59160ad791b3d3a1e5aaae2d9854188bc267b4d /dev-libs/mxml
parentmedia-sound/audiotag: EAPI=7 bump (diff)
downloadgentoo-a93da3634c0dd6e76ce9d7c349549f8c154a2393.tar.gz
gentoo-a93da3634c0dd6e76ce9d7c349549f8c154a2393.tar.bz2
gentoo-a93da3634c0dd6e76ce9d7c349549f8c154a2393.zip
dev-libs/mxml: bump to version 3.1
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12997 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest1
-rw-r--r--dev-libs/mxml/mxml-3.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index d8a015f79705..cec6fece84f9 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1 +1,2 @@
DIST mxml-3.0.tar.gz 9266886 BLAKE2B d5d3481cfd1d015c620ef897bfc21e839ad2a70f5ffd58973f8435e0e6a66abd477f8fcaacfab05ce608314fed27241702becb60b49b8492560bcc9418b317f5 SHA512 3c540348022226b122ce014f183368cda6631600a11d8f4d43c99c62fba2f3ca4b23dff4122082f63915b59a46a5475d1d12d0081f9315c65f5c044ac3c751d6
+DIST mxml-3.1.tar.gz 9267206 BLAKE2B d5cee24804978b474bf5b58c7a5932b50d7197a35e65da20c2517ce7db01d22027449348d6b15ddf0d186219ac81993055deaa4af9f48439273f8d2d74b27edd SHA512 8f8923b394093db5c471c52c17185916bc3c91f66c97de66919bfef2a09f271879a52f285e5fc4ded03484a3f83ba8fdb588d985b06e0c25ee001f1a80ffa586
diff --git a/dev-libs/mxml/mxml-3.1.ebuild b/dev-libs/mxml/mxml-3.1.ebuild
new file mode 100644
index 000000000000..d229322c4d4e
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os -g//' -i configure.ac || die
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}