summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-15 00:12:19 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-15 00:12:19 +0200
commit8b8dc14a04a52f3e60088512168fad3a8d091679 (patch)
tree72c2e35d656c8eccc332246a072ee81519be1ebc /dev-libs/libusb/libusb-1.0.23-r1.ebuild
parentdev-libs/libtasn1: drop 4.13, 4.15.0-r1 (diff)
downloadgentoo-8b8dc14a04a52f3e60088512168fad3a8d091679.tar.gz
gentoo-8b8dc14a04a52f3e60088512168fad3a8d091679.tar.bz2
gentoo-8b8dc14a04a52f3e60088512168fad3a8d091679.zip
dev-libs/libusb: drop 1.0.23-r1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libusb/libusb-1.0.23-r1.ebuild')
-rw-r--r--dev-libs/libusb/libusb-1.0.23-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-libs/libusb/libusb-1.0.23-r1.ebuild b/dev-libs/libusb/libusb-1.0.23-r1.ebuild
deleted file mode 100644
index ac3237f1c821..000000000000
--- a/dev-libs/libusb/libusb-1.0.23-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit multilib-minimal usr-ldscript
-
-DESCRIPTION="Userspace access to USB devices"
-HOMEPAGE="https://libusb.info/ https://github.com/libusb/libusb"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="1"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="debug doc examples static-libs test udev"
-RESTRICT="!test? ( test )"
-
-RDEPEND="udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP},static-libs(-)?] )"
-DEPEND="${RDEPEND}
- !udev? ( virtual/os-headers )"
-BDEPEND="doc? ( app-doc/doxygen )"
-
-multilib_src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable udev)
- $(use_enable debug debug-log)
- $(use_enable test tests-build)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- emake
-
- if multilib_is_native_abi; then
- use doc && emake -C doc docs
- fi
-}
-
-multilib_src_test() {
- emake check
-
- # noinst_PROGRAMS from tests/Makefile.am
- tests/stress || die
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-
- if multilib_is_native_abi; then
- gen_usr_ldscript -a usb-1.0
-
- use doc && dodoc -r doc/html
- fi
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f -name "*.la" -delete || die
-
- dodoc AUTHORS ChangeLog NEWS PORTING README TODO
-
- if use examples; then
- docinto examples
- dodoc examples/*.{c,h}
- docinto examples/getopt
- dodoc examples/getopt/*.{c,h}
- fi
-}