summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-17 00:06:28 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-17 00:08:06 +0200
commit48dbad9d52f5eaf5e4db9ba3ce1832f65a953389 (patch)
treef8af1c8615b7a56ad15363fccc887253cb847044 /dev-libs/libpeas
parentgnome-base/gnome-core-libs: bump to 3.34.4 (diff)
downloadgentoo-48dbad9d52f5eaf5e4db9ba3ce1832f65a953389.tar.gz
gentoo-48dbad9d52f5eaf5e4db9ba3ce1832f65a953389.tar.bz2
gentoo-48dbad9d52f5eaf5e4db9ba3ce1832f65a953389.zip
dev-libs/libpeas: bump to 1.26.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libpeas')
-rw-r--r--dev-libs/libpeas/Manifest1
-rw-r--r--dev-libs/libpeas/files/1.26.0-lua.patch89
-rw-r--r--dev-libs/libpeas/libpeas-1.26.0.ebuild77
3 files changed, 167 insertions, 0 deletions
diff --git a/dev-libs/libpeas/Manifest b/dev-libs/libpeas/Manifest
index cf8516a0bb09..3b9adef79413 100644
--- a/dev-libs/libpeas/Manifest
+++ b/dev-libs/libpeas/Manifest
@@ -1 +1,2 @@
DIST libpeas-1.22.0.tar.xz 561332 BLAKE2B 219918f8663cd60c9353f477ef905ce0d1e21bf5b7c09661c4cb3c8adbba3af9f5e93b9de8a1b098dab09b1f4071854a871c8ea1db878bda8fe9e51aa45e5f87 SHA512 9c1da1d4b5688c0f4d0647f3519dbfbed94c8921091057aaef0e41bf5ed3f8faf04a49ce9e4eea3fd7bf4ac4dfa1727d76a5f6dae2a4f52228d4c8c74b420c91
+DIST libpeas-1.26.0.tar.xz 191708 BLAKE2B 5845d5cb15724ba933572f48b9056a79cb2c167c7911ff1546c836fe56cd7e49d7461e5a413b79effa64e8e3fb2ed2eb370de665728e476e40ffb4d44c841543 SHA512 86157da14d17c16df2ef3f44ab48822ea1a8be8aec8f5419bc421bd475113f686cd16f9616ac53cbf3dc6f31f521384ac63eb8e9f1a46ea21b5cda8ba21e855f
diff --git a/dev-libs/libpeas/files/1.26.0-lua.patch b/dev-libs/libpeas/files/1.26.0-lua.patch
new file mode 100644
index 000000000000..0da1b148a49c
--- /dev/null
+++ b/dev-libs/libpeas/files/1.26.0-lua.patch
@@ -0,0 +1,89 @@
+From b693feda0148eb421e1f59d468caceb6f3183a82 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <mart@leio.tech>
+Date: Mon, 16 Mar 2020 23:43:12 +0200
+Subject: [PATCH] build: Handle lua as needed by Gentoo
+
+Gentoo currently uses unversioned lua:0 - lua.pc instad of lua5.1.pc,
+/usr/bin/lua instead of /usr/bin/lua5.1
+Additionally lua and luajit can be installed in parallel, but only one
+should be chosen - so add explicit meson options to choose between them.
+This is currently in a hacky un-upstreamable way: working correctly only
+if both options are disabled, or only one is enabled and the other
+disabled, but having logic issues if any is "auto" or both enabled; this
+is because feature option is mainly used to handle explicit choice
+between them more easily in a Gentoo-specific patch without having to
+add various conditional branches thanks to the feature being disabled
+acting as a full disabler, so the other option is automatically not
+checked.
+---
+ meson.build | 22 +++++++---------------
+ meson_options.txt | 5 ++++-
+ 2 files changed, 11 insertions(+), 16 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 8322fea..49e5011 100644
+--- a/meson.build
++++ b/meson.build
+@@ -117,18 +117,12 @@ endif
+
+ python2_dep = dependency('python2', version: python2_req, required: false)
+ pygobject_dep = dependency('pygobject-3.0', version: pygobject_req, required: false)
+-lua51_dep = dependency('lua51', version: lua_req, required: false)
+-if not lua51_dep.found()
+- lua51_dep = dependency('lua-5.1', version: lua_req, required: false)
+-endif
+-luajit_dep = dependency('luajit', version: luajit_req, required: false)
++lua51_dep = dependency('lua', version: lua_req, required: get_option('lua51'))
++luajit_dep = dependency('luajit', version: luajit_req, required: get_option('luajit'))
+ lua_lgi_found = false
+ lua_lgi_ver = 'not found'
+-lua51_prg = find_program('lua5.1', required: false)
+-if not lua51_prg.found()
+- lua51_prg = find_program('lua51', required: false)
+-endif
+-luajit_prg = find_program('luajit', required: false)
++lua51_prg = find_program('lua', required: get_option('lua51'))
++luajit_prg = find_program('luajit', required: get_option('luajit'))
+ xmllint_prg = find_program('xmllint', required: false)
+
+ if (luajit_dep.found() and luajit_prg.found()) or (lua51_dep.found() and lua51_prg.found())
+@@ -144,6 +138,8 @@ if (luajit_dep.found() and luajit_prg.found()) or (lua51_dep.found() and lua51_p
+ lua51_lgi_dep = declare_dependency(version: lua_lgi_ver)
+ lua_lgi_found = true
+ endif
++ else
++ error('lua support requested but lua-lgi not found')
+ endif
+ message('lua-lgi version: ' + lua_lgi_ver)
+ endif
+@@ -222,11 +218,7 @@ if generate_gir and not introspection_dep.found()
+ generate_gir = false
+ endif
+
+-build_lua51_loader = get_option('lua51')
+-lua51_found = (luajit_dep.found() or lua51_dep.found()) and lua_lgi_found
+-if build_lua51_loader and not lua51_found
+- build_lua51_loader = false
+-endif
++build_lua51_loader = (luajit_dep.found() or lua51_dep.found()) and lua_lgi_found
+
+ build_python2_loader = get_option('python2')
+ python2_found = python2_dep.found() and pygobject_dep.found()
+diff --git a/meson_options.txt b/meson_options.txt
+index 18e1779..dc3e776 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,6 +1,9 @@
+ option('lua51',
+- type: 'boolean', value: true,
++ type: 'feature', value: 'enabled',
+ description: 'Enable Lua 5.1 support (requires lua-lgi)')
++option('luajit',
++ type: 'feature', value: 'disabled',
++ description: 'Use LuaJIT for Lua 5.1 support (requires lua-lgi)')
+
+ option('python2',
+ type: 'boolean', value: false,
+--
+2.20.1
+
diff --git a/dev-libs/libpeas/libpeas-1.26.0.ebuild b/dev-libs/libpeas/libpeas-1.26.0.ebuild
new file mode 100644
index 000000000000..c7ca33771f79
--- /dev/null
+++ b/dev-libs/libpeas/libpeas-1.26.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit gnome.org meson python-single-r1 vala virtualx xdg
+
+DESCRIPTION="A GObject plugins library"
+HOMEPAGE="https://developer.gnome.org/libpeas/stable/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="glade +gtk gtk-doc lua luajit +python vala"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-1.39:=
+ gtk? ( >=x11-libs/gtk+-3.0.0:3[introspection] )
+ glade? ( >=dev-util/glade-3.9.1:3.10 )
+ lua? (
+ >=dev-lua/lgi-0.9.0
+ luajit? ( >=dev-lang/luajit-2:2 )
+ !luajit? ( =dev-lang/lua-5.1*:0 ) )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.2:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.11
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Gentoo-specific lua tweak hack
+ "${FILESDIR}"/${PV}-lua.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature $(usex lua !luajit lua) lua51)
+ $(meson_feature $(usex lua luajit lua) luajit)
+ -Dpython2=false
+ $(meson_use python python3)
+ # introspection was always enabled in autotools; would need readiness by consumers
+ # to USE flag it, but most need it for python plugins anyways
+ -Dintrospection=true
+ $(meson_use vala vapi)
+ $(meson_use gtk widgetry)
+ $(meson_use glade glade_catalog)
+ -Ddemos=false
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}