summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-12 23:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-13 16:50:49 +0100
commit6586c03bd709f716ac71c3bd0ea38f139529af54 (patch)
tree49af46265d080943050e638191140564f3367883 /dev-libs/liborcus
parentdev-libs/libixion: 0.16.1 version bump, no KEYWORDS for now (diff)
downloadgentoo-6586c03bd709f716ac71c3bd0ea38f139529af54.tar.gz
gentoo-6586c03bd709f716ac71c3bd0ea38f139529af54.tar.bz2
gentoo-6586c03bd709f716ac71c3bd0ea38f139529af54.zip
dev-libs/liborcus: 0.16.1 version bump, no KEYWORDS for now
Closes: https://bugs.gentoo.org/766965 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.16.1.ebuild63
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild4
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 65e49933c6c2..d43ffdc4292c 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1 +1,2 @@
DIST liborcus-0.15.4.tar.xz 1590048 BLAKE2B b2edff8a00439154c2850e49fff151f59c0c5a43163cebe5cac84b627fcf87c89a0a522797d8a5bc39eaca9205d74ff3f0bdf9ba77561c5cc7aefe98f35a4c8b SHA512 edbe1d6f86a249e43915e7fb960e6b269fa8703e3f571a023e811dd3f9b5d9c9a36edff491faa7ed7ea3490bf5afe1999e26d05c658a0a393b3ffd08b311b76f
+DIST liborcus-0.16.1.tar.xz 1805436 BLAKE2B 7df89da5a175daa6fcf759d28f8a0eaebf3db6405af3b06a01b8dad41c7706acedc74876a0b68ff9cabd5780bb7cb311cd7c98390c9ecd265e62513eadde81eb SHA512 6d75591820af65181dd3a418f051a359695083f29c7d9c77edbcab3e89d9ea367824be0b19f27a31267525f446936145f5780a0ce3c6ee2d89823742837d4739
diff --git a/dev-libs/liborcus/liborcus-0.16.1.ebuild b/dev-libs/liborcus/liborcus-0.16.1.ebuild
new file mode 100644
index 000000000000..668bff144022
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.16.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit python-single-r1
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+
+if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/9999"
+ EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+ inherit git-r3 autotools
+else
+ MDDS_SLOT="1/1.5"
+ SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
+# KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.16" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=[zlib(+)]
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( dev-libs/libixion:${SLOT} )
+"
+DEPEND="${RDEPEND}
+ dev-util/mdds:${MDDS_SLOT}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.15.4-gcc11.patch" ) # bug 764035
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --disable-werror
+ $(use_enable python)
+ $(use_enable spreadsheet-model)
+ $(use_with tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 215c415e3d80..50a9442c2807 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"