summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-06 06:22:08 +0100
committerSam James <sam@gentoo.org>2022-09-06 06:22:08 +0100
commit61356c092037eb481cdd120c51533b83f52a64e5 (patch)
tree8938aab939fcc4c3e938bca469c0bd582186db69 /dev-libs/libofx
parentmedia-fonts/lxgw-wenkai: add 1.240, drop 1.235.2 (diff)
downloadgentoo-61356c092037eb481cdd120c51533b83f52a64e5.tar.gz
gentoo-61356c092037eb481cdd120c51533b83f52a64e5.tar.bz2
gentoo-61356c092037eb481cdd120c51533b83f52a64e5.zip
dev-libs/libofx: refresh patch to match upstream variant (cosmetic)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libofx')
-rw-r--r--dev-libs/libofx/files/libofx-0.10.6-0002-autotools-fix-parallel-build-issue-with-ofxconnect-o.patch26
1 files changed, 21 insertions, 5 deletions
diff --git a/dev-libs/libofx/files/libofx-0.10.6-0002-autotools-fix-parallel-build-issue-with-ofxconnect-o.patch b/dev-libs/libofx/files/libofx-0.10.6-0002-autotools-fix-parallel-build-issue-with-ofxconnect-o.patch
index c6ac9035ff47..8288aac50947 100644
--- a/dev-libs/libofx/files/libofx-0.10.6-0002-autotools-fix-parallel-build-issue-with-ofxconnect-o.patch
+++ b/dev-libs/libofx/files/libofx-0.10.6-0002-autotools-fix-parallel-build-issue-with-ofxconnect-o.patch
@@ -1,6 +1,6 @@
https://github.com/libofx/libofx/pull/77
-From 8383d1245468db3aa944e77b38b681249073eb6b Mon Sep 17 00:00:00 2001
+From 55923eba7617c7c4056b21ddf3b569adaea43858 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Tue, 6 Sep 2022 06:00:04 +0100
Subject: [PATCH 2/2] autotools: fix parallel build issue with ofxconnect,
@@ -9,15 +9,31 @@ Subject: [PATCH 2/2] autotools: fix parallel build issue with ofxconnect,
We need to build the relevant tool before calling help2man, as
help2man tries to call the tool itself.
+Otherwise, we get:
+```
+help2man: can't get `--help' info from ./ofxdump
+Try `--no-discard-stderr' if option outputs to stderr
+make[2]: *** [Makefile:1211: ofxdump.1] Error 127
+make[2]: *** Waiting for unfinished jobs....
+```
+
+Ends up building okay as a workaround with -j1.
+
+Bug: https://github.com/libofx/libofx/pull/56
+See: 0597b8a0a9da3226af0779163fbb3ca389d70bc9
+Fixes: 76dae192b4bf642b311084043cf9d6273dd69bb2
Signed-off-by: Sam James <sam@gentoo.org>
--- a/ofxconnect/Makefile.am
+++ b/ofxconnect/Makefile.am
-@@ -25,7 +25,7 @@ EXTRA_DIST = cmdline.ggo test-privateserver.sh CMakeLists.txt
+@@ -23,9 +23,9 @@ EXTRA_DIST = cmdline.ggo test-privateserver.sh CMakeLists.txt
+
+ # See README.privateserver for details on this server and how to get
# the key needed to run this test.
- TESTS = test-privateserver.sh
+-TESTS = test-privateserver.sh
++TESTS = test-privateserver.sh
-ofxconnect.1: $(top_srcdir)/configure.ac
-+ofxconnect.1: $(top_srcdir)/configure.ac ofxconnect
++ofxconnect.1: ofxconnect$(EXEEXT)
if HAVE_HELP2MAN
$(HELP2MAN) -n 'Create a statement request file' -N --output=ofxconnect.1 ./ofxconnect$(EXEEXT)
else
@@ -28,7 +44,7 @@ Signed-off-by: Sam James <sam@gentoo.org>
endif
-ofxdump.1: $(top_srcdir)/configure.ac
-+ofxdump.1: $(top_srcdir)/configure.ac ofxdump
++ofxdump.1: ofxdump$(EXEEXT)
if HAVE_HELP2MAN
$(HELP2MAN) -n 'Dump content of OFX files as human-readable text' -N --output=ofxdump.1 ./ofxdump$(EXEEXT)
else