summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-08-21 00:50:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-08-21 01:29:12 +0200
commit251e6b6564bcbb2a8d161363235df986f40d1882 (patch)
treef88465c813d4ad32bc5888c1ac066ed37acfdd1d /dev-libs/libmodbus
parentdev-libs/intel-compute-runtime: drop 22.26.23599, 22.27.23681, 22.28.23726-r1 (diff)
downloadgentoo-251e6b6564bcbb2a8d161363235df986f40d1882.tar.gz
gentoo-251e6b6564bcbb2a8d161363235df986f40d1882.tar.bz2
gentoo-251e6b6564bcbb2a8d161363235df986f40d1882.zip
dev-libs/libmodbus: add 3.1.8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/libmodbus')
-rw-r--r--dev-libs/libmodbus/Manifest1
-rw-r--r--dev-libs/libmodbus/libmodbus-3.1.8.ebuild31
-rw-r--r--dev-libs/libmodbus/metadata.xml4
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libmodbus/Manifest b/dev-libs/libmodbus/Manifest
index fe81bf574a9b..fbf6b94a5550 100644
--- a/dev-libs/libmodbus/Manifest
+++ b/dev-libs/libmodbus/Manifest
@@ -1 +1,2 @@
DIST libmodbus-3.1.7.tar.gz 490162 BLAKE2B 3ba8353fbf6849597b1affdb8dc318b8dc1e2f66b0c1bc9f5f3c8286d48609be6d85d84269d31510fe292a48010a72e7a678b748f3c03117a6230651fa80fe91 SHA512 e2c00bd06d0b4a16c8edbfd25a95695b782cf459cd69a7cefc1cfa5e4025f23b2896487b48876ccf2f8050e8cdef4a76d322c9752a43cd8dd2c634df9406bada
+DIST libmodbus-3.1.8.tar.gz 459999 BLAKE2B e5cb17dd260f3d0a25aedb2cecaa35f21c116458b0a46c7fe3ecc51d6ceb162fa387bb3ad18ff78c89f39645184ecc5bb164ef7cef2d091d2727750bdb0e429a SHA512 1158ac52cf92d3f8f8afaa23b67e841018f94c09521464a4c28ab724f7f2beb0eb567d574c2d81cfb1e3df9436cd2635b52a886656985b27df3a27693957d2df
diff --git a/dev-libs/libmodbus/libmodbus-3.1.8.ebuild b/dev-libs/libmodbus/libmodbus-3.1.8.ebuild
new file mode 100644
index 000000000000..de8b52473bfe
--- /dev/null
+++ b/dev-libs/libmodbus/libmodbus-3.1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modbus library which supports RTU communication over a serial line or a TCP link"
+HOMEPAGE="https://libmodbus.org/"
+SRC_URI="https://github.com/stephane/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable test tests)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}
diff --git a/dev-libs/libmodbus/metadata.xml b/dev-libs/libmodbus/metadata.xml
index c07e13d4a6bd..669ea40be1ed 100644
--- a/dev-libs/libmodbus/metadata.xml
+++ b/dev-libs/libmodbus/metadata.xml
@@ -5,4 +5,8 @@
<email>conikost@gentoo.org</email>
<name>Conrad Kostecki</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://github.com/stephane/libmodbus/issues</bugs-to>
+ <remote-id type="github">stephane/libmodbus</remote-id>
+ </upstream>
</pkgmetadata>