summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmcal/libmcal-0.7-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmcal/libmcal-0.7-r5.ebuild')
-rw-r--r--dev-libs/libmcal/libmcal-0.7-r5.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/libmcal/libmcal-0.7-r5.ebuild b/dev-libs/libmcal/libmcal-0.7-r5.ebuild
new file mode 100644
index 000000000000..1255038a7a18
--- /dev/null
+++ b/dev-libs/libmcal/libmcal-0.7-r5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+DRIVERS="mcaldrivers-0.9"
+SRC_URI_BASE="mirror://sourceforge/libmcal"
+DESCRIPTION="Modular Calendar Access Library"
+HOMEPAGE="http://mcal.chek.com/"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.gz ${SRC_URI_BASE}/${DRIVERS}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="pam"
+
+DEPEND="pam? ( virtual/pam )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv ${S}/../mcal-drivers/* ${S}/
+ einfo "Using /var/spool/calendar instead of /var/calendar"
+ for i in FAQ-MCAL HOW-TO-MCAL mstore/mstore.c mstore/README mstore/Changelog; do
+ sed -e 's|/var/calendar|/var/spool/calendar|g' -i ${i}
+ done
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fpic.patch
+ epatch ${FILESDIR}/${P}-libdir.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-flexfix.patch
+}
+
+src_compile() {
+ use pam && CFLAGS="${CFLAGS} -DUSE_PAM -lpam" LDFLAGS="${LDFLAGS} -lpam"
+ einfo "Setting up mstore back-end"
+ cd ${S}/mstore
+ emake CFLAGS="${CFLAGS} -I.." LDFLAGS="${LDFLAGS}" || die
+
+ einfo "Setting up icap back-end"
+ cd ${S}/icap
+ emake CFLAGS="${CFLAGS} -I.." LDFLAGS="${LDFLAGS}" || die
+
+ cd ${S}
+ myconf="--with-mstore --with-icap"
+ econf ${myconf} --libdir=/usr/$(get_libdir) || die
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc CHANGELOG FAQ-MCAL FEATURE-IMPLEMENTATION HOW-TO-MCAL LICENSE README
+ newdoc mstore/README mstore-README
+ newdoc mstore/Changelog mstore-Changelog
+ newdoc icap/Changelog icap-Changelog
+ dohtml FUNCTION-REF.html
+ keepdir /var/spool/calendar
+ fperms 1777 /var/spool/calendar
+}
+
+pkg_postinst() {
+ einfo "You should start adding users to your calendar. ( e.g. htpasswd -c /etc/mpasswd username )"
+ # enforce perms
+ chmod 1777 ${ROOT}/var/spool/calendar
+}