summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-12 20:52:11 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-12 20:52:11 -0400
commitea3bff66c8fa4274cab56b0ca508d3e1f707bdcd (patch)
treeb464a97f2d3e27e9de6017e4f985cbb45a3d6618 /dev-libs/libintl
parentvirtual/libintl: fix thinko: libiconv->libintl (diff)
downloadgentoo-ea3bff66c8fa4274cab56b0ca508d3e1f707bdcd.tar.gz
gentoo-ea3bff66c8fa4274cab56b0ca508d3e1f707bdcd.tar.bz2
gentoo-ea3bff66c8fa4274cab56b0ca508d3e1f707bdcd.zip
dev-libs/libintl: drop USE=nls flag
The related commit in gettext (030b323567f9546c35d9cf1182f36b2b54e08) was wrong -- the internal configure logic skips the libintl flag when nls support is disabled. It doesn't matter there now as libintl has been dropped, but it still matters here as w/out the flag, no library is built. So drop the flag, hardcode the option, and add a comment to keep from screwing it up in the future.
Diffstat (limited to 'dev-libs/libintl')
-rw-r--r--dev-libs/libintl/libintl-0.19.6.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-libs/libintl/libintl-0.19.6.ebuild b/dev-libs/libintl/libintl-0.19.6.ebuild
index 4da925bef550..5c788265faa7 100644
--- a/dev-libs/libintl/libintl-0.19.6.ebuild
+++ b/dev-libs/libintl/libintl-0.19.6.ebuild
@@ -17,7 +17,7 @@ SRC_URI="mirror://gnu/gettext/${MY_P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="nls static-libs +threads"
+IUSE="static-libs +threads"
DEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]"
# Block C libraries known to provide libintl.
@@ -28,7 +28,9 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}/gettext-runtime"
src_prepare() {
- elibtoolize
+ # The libtool files are stored higher up, so make sure we run in the
+ # whole tree and not just the subdir we build.
+ elibtoolize "${WORKDIR}"
}
multilib_src_configure() {
@@ -36,6 +38,9 @@ multilib_src_configure() {
# Emacs support is now in a separate package.
--without-emacs
--without-lispdir
+ # Normally this controls nls behavior in general, but the libintl
+ # subdir is skipped unless this is explicitly set. ugh.
+ --enable-nls
# This magic flag enables libintl.
--with-included-gettext
# The gettext package provides this library.
@@ -44,7 +49,6 @@ multilib_src_configure() {
# No java until someone cares.
--disable-java
- $(use_enable nls)
$(use_enable static-libs static)
$(use_enable threads)
)