summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-20 04:11:30 +0000
committerSam James <sam@gentoo.org>2023-01-20 04:11:30 +0000
commit5a676e6198e558a1d71b36028e3face9e614ea33 (patch)
tree14a6e1713d8cd8a2b9ea961ca4ffc50ba806e7b1 /dev-libs/libinput
parentmedia-gfx/prusaslicer: Stabilize 2.5.0-r1 amd64, #891413 (diff)
downloadgentoo-5a676e6198e558a1d71b36028e3face9e614ea33.tar.gz
gentoo-5a676e6198e558a1d71b36028e3face9e614ea33.tar.bz2
gentoo-5a676e6198e558a1d71b36028e3face9e614ea33.zip
dev-libs/libinput: fix build w/ sphinx 6
Closes: https://bugs.gentoo.org/889908 Bug: https://bugs.gentoo.org/891371 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/files/libinput-1.22.1-sphinx-6.patch28
-rw-r--r--dev-libs/libinput/libinput-1.22.1.ebuild4
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libinput/files/libinput-1.22.1-sphinx-6.patch b/dev-libs/libinput/files/libinput-1.22.1-sphinx-6.patch
new file mode 100644
index 000000000000..737ac3965c7a
--- /dev/null
+++ b/dev-libs/libinput/files/libinput-1.22.1-sphinx-6.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/891371
+https://bugs.gentoo.org/889908
+https://gitlab.freedesktop.org/libinput/libinput/-/commit/bf2e8a406e6ebfdb62ffa67f00822c17ff9b2c6a
+
+From bf2e8a406e6ebfdb62ffa67f00822c17ff9b2c6a Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Tue, 17 Jan 2023 12:28:58 +1000
+Subject: [PATCH] doc/user: fix sphinx warning
+
+WARNING: extlinks: Sphinx-6.0 will require a caption string to contain
+exactly one '%s' and all other '%' need to be escaped as '%%'.
+
+Well, let's do that then!
+
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+--- a/doc/user/conf.py.in
++++ b/doc/user/conf.py.in
+@@ -169,7 +169,7 @@ from recommonmark.parser import CommonMarkParser
+
+ extlinks = { 'commit' :
+ ('https://gitlab.freedesktop.org/libinput/libinput/commit/%s',
+- 'git commit ')
++ 'git commit %s')
+ }
+
+ # -- git version hack -------------------------------------------------
+--
+GitLab
diff --git a/dev-libs/libinput/libinput-1.22.1.ebuild b/dev-libs/libinput/libinput-1.22.1.ebuild
index a6741dc43f7b..70cad76124a2 100644
--- a/dev-libs/libinput/libinput-1.22.1.ebuild
+++ b/dev-libs/libinput/libinput-1.22.1.ebuild
@@ -44,6 +44,10 @@ BDEPEND="
"
# test? ( dev-util/valgrind )
+PATCHES=(
+ "${FILESDIR}"/${P}-sphinx-6.patch
+)
+
python_check_deps() {
python_has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
python_has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \