summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libindicate-qt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libindicate-qt/files')
-rw-r--r--dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch b/dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch
new file mode 100644
index 000000000000..70a54fdbe6f8
--- /dev/null
+++ b/dev-libs/libindicate-qt/files/libindicate-qt-0.2.5.91-optionaltests.patch
@@ -0,0 +1,24 @@
+https://code.launchpad.net/~ballogy/libindicate-qt/make-examples-and-tests-optional/+merge/82829
+=== modified file 'CMakeLists.txt'
+--- CMakeLists.txt 2010-03-08 09:02:19 +0000
++++ CMakeLists.txt 2011-11-20 20:28:23 +0000
+@@ -36,8 +36,16 @@
+ DESTINATION lib${LIB_SUFFIX}/pkgconfig)
+
+ add_subdirectory(src)
+-add_subdirectory(examples)
+-add_subdirectory(tests)
++
++option( BUILD_EXAMPLES "build examples" ON )
++if (BUILD_EXAMPLES)
++ add_subdirectory(examples)
++endif (BUILD_EXAMPLES)
++
++option( BUILD_TESTS "build tests" ON )
++if (BUILD_TESTS)
++ add_subdirectory(tests)
++endif (BUILD_TESTS)
+
+ # Packaging
+ set(ARCHIVE_NAME libindicate-qt-${indicate_qt_VERSION})
+