summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-06-24 18:02:05 +0200
committerSebastian Pipping <sping@gentoo.org>2017-06-24 18:02:05 +0200
commit296e68a1e42a72dd375f50b03f1e73d02d82a874 (patch)
tree302d5846d7eeeb72e0d136926b43a20752d63208 /dev-libs/libbsd
parentx11-themes/kfaenza: Drop old (diff)
downloadgentoo-296e68a1e42a72dd375f50b03f1e73d02d82a874.tar.gz
gentoo-296e68a1e42a72dd375f50b03f1e73d02d82a874.tar.bz2
gentoo-296e68a1e42a72dd375f50b03f1e73d02d82a874.zip
dev-libs/libbsd: 0.8.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.8.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index b702e549981d..e8fec63467c7 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1,3 +1,4 @@
DIST libbsd-0.8.2.tar.xz 344292 SHA256 b2f644cae94a6e2fe109449c20ad79a0f6ee4faec2205b07eefa0020565e250a SHA512 2230d51a30a0c3a8518c7e325036d2b578c8c2b47525c2d0d5f530d28d82227ad48b50341e44521db21f99208fe7c0df7313254c90e3c92da1c8664a8cbb87c5 WHIRLPOOL 4f9b09aaa7c0775cd46bf0aaaba9e9a7f07040262739002bf3966aace3bb4d782f96b176e2c489e7d7cbc0840eecc463a414dee1b5c92414c9a821796d739290
DIST libbsd-0.8.3.tar.xz 356772 SHA256 934b634f4dfd865b6482650b8f522c70ae65c463529de8be907b53c89c3a34a8 SHA512 155b895d6bd62b180718d65a2cda7484946c492d52735a57b51005705dfe4528b6a72e8745acea47b01fe68e3bbbe3c036c5e9998a8d06fc79efe2b96a04767f WHIRLPOOL ab74a85813ea3308e7e4c53b7a46f4b93e4dff4d091964a6347f9960729e8eb4c8a2a0866938de508caf47caf9371f14499fcb0cc4aa30da06f501f4ccad9ef2
DIST libbsd-0.8.4.tar.xz 368396 SHA256 217af1642915703151ea6df077311633dd6ad7bfa3c7e07dd9329a93f642cab3 SHA512 83ca4733edad918a51096301480b702be96f064d7e731cc0870a78d6505574ac6f4edc101aae8b97ff430b2b3ae99e162660e7e3933d05caa14537e581926dc3 WHIRLPOOL 9e0cf7b0db53659d3cce19d2906092298da272dd52489f0820fc1df8a074c7f15e85b3fc4abf82e26b3c311df35ebdc96f06000f580458dc371eab0387d05a67
+DIST libbsd-0.8.5.tar.xz 370680 SHA256 7647d024f41389305272c263da933a6f2a978213c1801592f47e68d83ac05b28 SHA512 bb122862ce8b789e530e9ca1a777d4219db2066ad89fe6028a833a5dc33ac0cd6b553ef5a0a42962d4a594c1f410304fd553b8fab583db539989ec7cca85baf0 WHIRLPOOL 6a621bf56ec6660cef7663dec62c0623d85931a56239f435e60bff7df8c4150ef378bff03801f67f798d0e640dc1dd061457a3b6df6a2f3f20a03b66fba14ebd
diff --git a/dev-libs/libbsd/libbsd-0.8.5.ebuild b/dev-libs/libbsd/libbsd-0.8.5.ebuild
new file mode 100644
index 000000000000..c9b85c118e93
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.8.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-3.17"
+RDEPEND=""
+
+pkg_setup() {
+ local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ find "${ED}" -name "*.la" -delete || die
+}