summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-21 11:00:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-21 16:34:51 +0100
commit12a66c962b61f0236cdaec44f026a84704857370 (patch)
tree0f3c85b85b2b3afe787039176c34b4c3b7800448 /dev-libs/kopeninghours
parentapp-office/merkuro: 24.02.1 version bump (diff)
downloadgentoo-12a66c962b61f0236cdaec44f026a84704857370.tar.gz
gentoo-12a66c962b61f0236cdaec44f026a84704857370.tar.bz2
gentoo-12a66c962b61f0236cdaec44f026a84704857370.zip
dev-libs/kopeninghours: 24.02.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 3e9d09005d90..118f9c008637 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-23.08.5.tar.xz 72568 BLAKE2B 84e418d95f4a7261786a101882000bed0ca721931cc419e0330edb0f659e38459063d49c75ca643d169e9326ed66694130cfeebef51183c89e02efd02f6f3133 SHA512 a95cd3c446699d8bd95f2f746cb8b4187c7d2027067e5c731afe371a3313a5569780110e8acbf52d125da673aff4b2567da9f2b8c07a4412cf1d7540baad7a14
DIST kopeninghours-24.02.0.tar.xz 72732 BLAKE2B 8669a7c0e8c6a44899ed5a0f2d50d023813a5756483b8c43caf2c9218a89f46d56e7b3bcb480c8be42510bf85722364067448ead546ceeae7fc18deaef7f2874 SHA512 9a445f00b75afb91aad28e50106ded63fe92a258be8722514c22f562a49a539242f8f30f053689d91928ff0b9cef4fee00df3efb67e65ce48226ec3e6983b359
+DIST kopeninghours-24.02.1.tar.xz 73344 BLAKE2B 4102d4040cea716bf1c12faca7aebf46d22636d2360c554d281f1b67ac9fa46d9b45a7d2d2a84500b2169a7639f1f892bd85899493f2bef0ebcc58f42802655a SHA512 126426103cff6974fa995356df67988dd8438e20ec2d9aa407e396d6971b2fe422e1009331d4d740da4a04eb04ac83eb2b493766b7d7af04209779ed6b9358da
diff --git a/dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild b/dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild
new file mode 100644
index 000000000000..796172457765
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}