summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-03-27 20:44:35 +0200
committerAaron Bauman <bman@gentoo.org>2018-03-30 13:14:23 -0400
commitab035b1dbd390143b3f34ac7084790e1fbfb2769 (patch)
treedc0a5d4135cfc504bdc9e580e55b0a0177342d02 /dev-libs/jsoncpp
parentmedia-video/jubler: remove unused file (diff)
downloadgentoo-ab035b1dbd390143b3f34ac7084790e1fbfb2769.tar.gz
gentoo-ab035b1dbd390143b3f34ac7084790e1fbfb2769.tar.bz2
gentoo-ab035b1dbd390143b3f34ac7084790e1fbfb2769.zip
dev-libs/jsoncpp: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/7656
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch25
-rw-r--r--dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch55
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch b/dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch
deleted file mode 100644
index 838ef8487946..000000000000
--- a/dev-libs/jsoncpp/files/jsoncpp-0.10.2-arm.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 96412d2964775fd6fb9bf359936743dd508af8ba Mon Sep 17 00:00:00 2001
-From: Christopher Dunn <cdunn2001@gmail.com>
-Date: Wed, 10 Jun 2015 21:22:24 -0500
-Subject: [PATCH] fix #290
-
-(cherry picked from commit 2760c7902a5cc7173aabe4e1f31dcf93e79377d5)
----
- src/test_lib_json/main.cpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/test_lib_json/main.cpp b/src/test_lib_json/main.cpp
-index 85110ad..080ba6e 100644
---- a/src/test_lib_json/main.cpp
-+++ b/src/test_lib_json/main.cpp
-@@ -296,7 +296,10 @@ JSONTEST_FIXTURE(ValueTest, null) {
- JSONTEST_ASSERT_EQUAL(0.0, null_.asFloat());
- JSONTEST_ASSERT_STRING_EQUAL("", null_.asString());
-
-+#if !defined(__ARMEL__)
-+ // See line #165 of include/json/value.h
- JSONTEST_ASSERT_EQUAL(Json::Value::null, null_);
-+#endif
- }
-
- JSONTEST_FIXTURE(ValueTest, strings) {
diff --git a/dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch b/dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch
deleted file mode 100644
index 5c3420e45004..000000000000
--- a/dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From e6f1cffdd3fb04a0ed96319e6f8df6a7cbdd1557 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 19 May 2015 17:32:31 +0200
-Subject: [PATCH] Fix custom includedir & libdir substitution in pkg-config
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Do not prepend ${prefix} to substituted includedir & libdir
-in the pkg-config file -- if the paths are overriden by user, CMake puts
-absolute paths there (even if user specifies a relative path). Instead,
-use the absolute path provided by CMake and appropriately default
-LIBRARY_INSTALL_DIR & INCLUDE_INSTALL_DIR to absolute paths with
-${CMAKE_INSTALL_PREFIX} prepended.
-
-Fixes: https://github.com/open-source-parsers/jsoncpp/issues/279
-Signed-off-by: Michał Górny <mgorny@gentoo.org>
----
- CMakeLists.txt | 6 +++---
- pkg-config/jsoncpp.pc.in | 4 ++--
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 30038d5..d31a6ad 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -25,11 +25,11 @@ SET(LIB_SUFFIX "" CACHE STRING "Optional arch-dependent suffix for the library i
-
- SET(RUNTIME_INSTALL_DIR bin
- CACHE PATH "Install dir for executables and dlls")
--SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX}
-+SET(ARCHIVE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}
- CACHE PATH "Install dir for static libraries")
--SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX}
-+SET(LIBRARY_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}
- CACHE PATH "Install dir for shared libraries")
--SET(INCLUDE_INSTALL_DIR include
-+SET(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include
- CACHE PATH "Install dir for headers")
- SET(PACKAGE_INSTALL_DIR lib${LIB_SUFFIX}/cmake
- CACHE PATH "Install dir for cmake package config files")
-diff --git a/pkg-config/jsoncpp.pc.in b/pkg-config/jsoncpp.pc.in
-index 9613181..3ca4a84 100644
---- a/pkg-config/jsoncpp.pc.in
-+++ b/pkg-config/jsoncpp.pc.in
-@@ -1,7 +1,7 @@
- prefix=@CMAKE_INSTALL_PREFIX@
- exec_prefix=${prefix}
--libdir=${exec_prefix}/@LIBRARY_INSTALL_DIR@
--includedir=${prefix}/@INCLUDE_INSTALL_DIR@
-+libdir=@LIBRARY_INSTALL_DIR@
-+includedir=@INCLUDE_INSTALL_DIR@
-
- Name: jsoncpp
- Description: A C++ library for interacting with JSON