summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-02-08 19:46:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-02-08 22:47:31 +0100
commit2847b771cef681bc7bcbbc7252eb1a91de79476f (patch)
treebf5cf148608c3a8e73e5b5f8a8c072d591b1d8e1 /dev-libs/intel-compute-runtime
parentdev-libs/intel-compute-runtime: amd64 stable (diff)
downloadgentoo-2847b771cef681bc7bcbbc7252eb1a91de79476f.tar.gz
gentoo-2847b771cef681bc7bcbbc7252eb1a91de79476f.tar.bz2
gentoo-2847b771cef681bc7bcbbc7252eb1a91de79476f.zip
dev-libs/intel-compute-runtime: drop 23.35.27191.9
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 4af3443a79f2..a5ae0bbaeb4b 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1 @@
-DIST intel-compute-runtime-23.35.27191.9.tar.gz 6856146 BLAKE2B 02676adde05bef374f12ca6d6baac1a577ae32b712e77bf01e09d6cc01a2eeeb4d6eacc8fb302e350aca34f9d70f07a20ac70a52a682bdefb06223c4b6611cf7 SHA512 39abd4830ce379894bd9f17e2a1685b6403ddd13bae1fb1549c11de3e4b26536adfb24194c245466c45ba01c9d89c5d69bb60fbb498d9c23c24d31b018a37af8
DIST intel-compute-runtime-23.48.27912.9.tar.gz 6842680 BLAKE2B 599ac52a176f05a5f6770bf0be4e1f899a9ea378b3a5ef2bc13f61e9706a3abfc7c8c2ebc7c17e64baf71f0bb73904ef80b1c0391d91790ae1db81f7fc5d5c03 SHA512 8c8fa6aa40f25871d9b2b61035c1a539d18d2f521424e925ecdcd89336b948e24784ae0a795811e0defeb6c295e7b175e4af525d4fcb24bd62852f6cd07584af
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild
deleted file mode 100644
index 1a6f3bed6576..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.3.5:="
-
-DEPEND="
- ${DEPEND}
- dev-libs/intel-metrics-discovery:=
- dev-libs/intel-metrics-library:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.15136.4
- >=dev-util/intel-graphics-system-controller-0.8.13:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.14.0:= )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- media-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=(
- "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
-)
-
-src_prepare() {
- # Remove '-Werror' from default
- sed -e '/Werror/d' -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-lto
-
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}