summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-02-12 11:28:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-02-12 11:29:36 +0100
commit3a10b4adcdfe384657d9f6e6ff5b489c55c92771 (patch)
tree036db6d794d560f210af0d04ef38ae7af644f755 /dev-libs/inih
parentsys-fs/eudev: Stabilize 3.2.10 sparc, #769713 (diff)
downloadgentoo-3a10b4adcdfe384657d9f6e6ff5b489c55c92771.tar.gz
gentoo-3a10b4adcdfe384657d9f6e6ff5b489c55c92771.tar.bz2
gentoo-3a10b4adcdfe384657d9f6e6ff5b489c55c92771.zip
dev-libs/inih: Bump to version 53
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest1
-rw-r--r--dev-libs/inih/inih-53.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index c1568bd6205f..e04105df23e4 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1,2 +1,3 @@
DIST inih-51.tar.gz 16258 BLAKE2B 91a5aee6e0ecadf949fbf0b58bd2596bcb985c76fc9000a671d65cb5325c51dbb8bd945ccd7721b72dafafd11c70a9c84ad910768d0fc479e5491db8b7aacbd8 SHA512 eb2f58979d93e51a09326e6c187828643887ac1a239d4b12205567c7d87a671c9c49ca99db376c031d366bc680e579c30dcea9f3eb130ec802597411b2cb3cf4
DIST inih-52.tar.gz 16808 BLAKE2B 12d4078ad7b6a4013ea77239c486fb7b5e9165252d4a67ee57d60fc72a98f15ca537b610c7b22841cc660e46bb424aa5c9b7ed1cf2462600a2aa58d40447ba90 SHA512 14c0d0dbd78efc99bec8df12067107d130eef8b124e0616f7d83dc4e14530b57f0c8fcf0b8862d425b5a0b84d6c6a6bff7b3c852c9b2e2364ef56c8f64a1f339
+DIST inih-53.tar.gz 16984 BLAKE2B 1242e6273c9dd9a11ea026a3495a487b2aa72d8e01f34304d8568c88897ae9c9bb425246f992dc16f4dc2210ec14c597d0ef595cec84ff98a5d6101ee5a643b9 SHA512 99bc40c294b521e9973184bfb30d60c129735991f33b387b3d023827a34672b0489eadf91e38895ea725168dbc7b27bb02c1975debe7573b4b209d0e947b2100
diff --git a/dev-libs/inih/inih-53.ebuild b/dev-libs/inih/inih-53.ebuild
new file mode 100644
index 000000000000..288ada671b4b
--- /dev/null
+++ b/dev-libs/inih/inih-53.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+IUSE="static-libs"
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=(
+ LICENSE.txt
+ README.md
+ )
+ einstalldocs
+}