summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-05-03 15:33:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-12 16:57:07 +0300
commit9b5e22f9d13c4ec9ed36749b81f9da2c817b7009 (patch)
tree8fc43c15260aa7a517b067c8289f79754f98d670 /dev-libs/ilbc-rfc3951
parentwww-client/qutebrowser: Drop old versions (diff)
downloadgentoo-9b5e22f9d13c4ec9ed36749b81f9da2c817b7009.tar.gz
gentoo-9b5e22f9d13c4ec9ed36749b81f9da2c817b7009.tar.bz2
gentoo-9b5e22f9d13c4ec9ed36749b81f9da2c817b7009.zip
dev-libs/ilbc-rfc3951: add blocker against media-libs/libilbc.
media-libs/libilbc seems to be a drop-in replacement for dev-libs/ilbc-rfc3951. I intend to retire ilbc-rfc3951 as I've already switched asterisk to media-libs/libilbc. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/15624 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/ilbc-rfc3951')
-rw-r--r--dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild
new file mode 100644
index 000000000000..e0e5d1ce1547
--- /dev/null
+++ b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="iLBC is a speech codec suitable for robust voice communication over IP"
+HOMEPAGE="https://webrtc.org/license/ilbc-freeware/"
+SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz -> ${P}.tar.gz"
+
+# relicensed under 3-clause BSD license, bug 390797
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-asneeded.patch )
+
+RDEPEND="!media-libs/libilbc"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}